스프링부트 Gradle 버전 변경하기

deepen·2020년 8월 4일
0

springboot 설정을 하면서 플러그인 추가에 문제가 발생했다. 5.6.x 이거나 6.3 이상이어야 한다고 했는데 내 설정은 6.1로 기본 설정되어있었다.

그래서 원인은 gradle 버전과 springboot 플러그인 사이 충돌이어서 gradle 버전을 변경해서 해결했다.
<gradle은 java 8 이상이어야 한다.>

gradlew 명령어로 버전 변경하기

버전을 바꾸고자 하는 프로젝트 내부로 이동한 뒤
gradle의 버전을 확인한다.(환경변수 및 설치 여부도 확인 가능한 명령어이다.)

% ./gradle -v

한 프로젝트에 여러 명이 참여할 경우 gradle 버전이 다른 경우가 있는데, wrapper 파일을 사용하면 다른 환경에서도 버전 일관성이 유지되어 효율적이다.
wrapper은 wrapper에 선언된 gradle 버전을 호출하여 필요한 경우 미리 다운로드하는 스크립트이다. 그러므로 개발자는 수동으로 설치하지 않고 gradle 프로젝트를 신속하게 시작 가능하다.
아래 command를 입력하면 wrapper 파일이 생성되고, gradle-wrapper.properties라는 속성 파일도 생성된다.

% gradle wrapper

터미널에서 gradle wrapper을 이용해 버전을 변경한다.

% ./gradlew wrapper --gradle-version 변경할버전

터미널에 명령어를 입력한다.

그러면 변경되었다는 표시와 함께 프로젝트 설정에서도 변경되어서 플러그인이 정상적으로 추가되어진다.

터미널에서 확인하고 싶으면 gradlew 명령어를 사용하면 된다.

% ./gradlew -v

gradle wrapper 관련 문서
https://docs.gradle.org/current/userguide/gradle_wrapper.html

++8.12 수정
gradle 5에서는 lombok 및 플러그인들의 설정 방법이 변경되었지만, 인터넷에서는 gradle 4로 설정된 자료들이 많아서 기본적인 공부를 위해 gradle 4.10.2로 낮춰서 사용하고 있다.
gradlew와 gradle의 차이는 gradlew는 사용자가 wrapper을 사용하고 있음을 나타낸다는 것이다.

profile
함께 성장하는 개발자가 되고 싶습니다!

0개의 댓글