manjaro 에서 pacman 이용시 pgp 에러 발생시

gadian88·2020년 5월 2일
0
  • pacman -Syyu 입력시 다음 에러가 발생할경우
$ pacman -Syyu
error: fzf: signature from "Ambrevar <ambrevar@gmail.com>" is unknown trust :: File /var/cache/pacman/pkg/fzf-0.17.0.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
  • 다음 명령어로 해결한다.
sudo pacman-key --refresh-keys
  • 다음 에러가 추가 발생시
$ sudo pacman -Syu
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
  • 다음 명령어를 입력한다.
sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
  • 다음에 다시한번 확인한다.
sudo pacman -Syyu

원인은 자세하게 확인해봐야 하겠지만 업데이트 서버에 있는 서명과 내노트북에 있는 서명값이 달라서 생긴것 같다.

profile
블로그 이전 중 (https://www.notion.so/My-blog-0d569b9028434fb6a99a3e66b6e807b1)

0개의 댓글