Angular 6 프로젝트를 Angular 7로 업데이트 후에 모든 의존성 모듈도 최신 버전으로 올리니 빌드 실패!! 를 해결하기 위해 1시간 정도 삽질.

일단 앵귤러 뿐만 아니라 node.js 관련 모듈을 사용할 때 공통적으로 적용될 듯 하다.

시도 1

빌드가 안 되니 급한 마음에 다시 앵귤러6 때로 하드 reset => 빌드 실패! ???

시도 2

node_modules 폴더 삭제후 npm install 시전 => 빌드 실패!

시도 3

특정 모듈이 메이저 업데이트되면서 패키지명이 바뀌어 버린 것을 발견. 파일마다 import 문을 수정 => 빌드 실패!

시도 4

stackOverflow에서 비슷한 에러를 여럿 발견. firebase 와 firebase-admin을 순서를 바꿔서 설치했더니 되더라는 글 발견 => 나는 안 됨!

시도 5

stackOverflow에서 import 문을 바꿨더니 되더라 => 나는 안 됨!

시도 6

stackOverflow에서 이건 버그다! 예전 버전으로 돌려라 => 나는 안 됨!

시도 7

stackOverflow에서 package-lock.json, node_modules 삭제 후 재설치 => 빌드 성공!

결론

package-lock.json 에 구버전 내용이 남아있는 것이 원인. package-lock.json, node_modules 를 모두 삭제한 후 의존성 모듈을 모두 재설치하여 해결.