😵 Error

Google Cloud SDK(이하 gcloud)를 설치하던 중 에러가 발생했다!!
바이너리를 다운 받아 사용하는 방법도 있지만 apt를 통해서 설치를 진행하고자 하였다.

아래는 해당 스크립트이다
apt-get를 사용하여 설치하기 - Google Cloud Platform

export CLOUD_SDK_REPO="cloud-sdk-$(lsb_release -c -s)"
echo "deb http://packages.cloud.google.com/apt $CLOUD_SDK_REPO main" | sudo tee -a /etc/apt/sources.list.d/google-cloud-sdk.list
curl https://packages.cloud.google.com/apt/doc/apt-key.gpg | sudo apt-key add -
sudo apt-get update && sudo apt-get install google-cloud-sdk

하지만 이 스크립트를 실행하던 도중 apt-get update에서 에러가 터졌다

해당 repo가 없다고 하는데.. 순간 나는 deepin 이라서 당하는 일도 생기는 건가, 라고 생각했다 XD

🔜 Catch

계속 구글링을 하다가 안 되겠어서 해당 사이트, 디렉토리 리스트를 보았다.
https://packages.cloud.google.com/apt/dists

image.png

그 순간 나는 알았다, - 가 없어서 라는 걸

스크립트를 볼 때 디렉토리 명은 cloud-sdk-$(lsb_release -c -s)와 같은 형식을 띈다

하지만 내가 사용하는 DEEPIN은 Debian unstable 브런치에서 나온 배포판이기 때문에 cloud-sdk-unstable이 되는데 디렉토리를 보니까 cloud-sdk--unstable로 되어있다. 그래서 앞에 - 하나 더 달아줬더니 바로 잘 작동하더라

그리고 gcloud 너무 편하다 :) 개인적으로 aws보다 좋아한다

❓ Why

이 글을 적어 놓는 이유는 정말 간단하다

  1. 나 같이 삽질 하지 않았으면 좋겠다
  2. 저기에 대해 어떻게 연락해야 될지 조언을 얻고 싶어서..

PS. 아아.. 내 시간 ㅠㅜ, -땜에..