Cannot import javax.validation.constraints

pyeeun·2021년 6월 25일
0


스프링 실습을 하던 중, javax.validation 패키지 import 오류가 발생했다.
음? 찾아보니까 스프링부트 2.3.0 버전부터는 web-startervalidation 패키지가 제외되어 별도로 dependency 지정이 필요하다고 한다.


1. Maven - dependency 추가

pom.xml 파일에 아래와 같이 dependency 를 추가한다.

<dependency>
	<groupId>org.springframework.boot</groupId>
	<artifactId>spring-boot-starter-validation</artifactId>
</dependency>



2. Gradle - dependency 추가

build.gradle 파일에 아래와 같이 dependency를 추가한다.

dependencies {
    implementation 'org.springframework.boot:spring-boot-starter-validation'
}


더 자세한 내용을 알고 싶으면, 아래 링크를 참고하자.
참고 : https://github.com/spring-projects/spring-boot/wiki/Spring-Boot-2.3-Release-Notes

profile
소소한 일상을 담는

0개의 댓글