[Vue] fsevents, node-gyp 와 No Xcode 문제 해결

rnfh1111·2020년 3월 7일
0

문제

yarn으로 패키지 설치, 제거 명령을 실행하면

 Warn: ~~~~ /nodemodule/fsevent ~~~

라는 문구와 함께

 node-gyp ~~~~
 gyp ERR! ~~~~
 ....
 No receipt for 'com.apple.pkg.CLTools_Executables' found at '/'.

No receipt for 'com.apple.pkg.DeveloperToolsCLILeo' found at '/'.

No receipt for 'com.apple.pkg.DeveloperToolsCLI' found at '/'.

gyp: No Xcode or CLT version detected! I'M RUNNING XCODE 11.2beta

라는 오류가 발생한다.

문제가 발생한 시키는 아마 vue cli를 4.2.2 -> 4.2.3 으로 업데이트 하고 나서 발생 한 것 같다.

환경

우선 해결하기 앞서 문제가 발생한 환경은

이고 vue-cli 버전은 4.2.3 이다.

해결

1. yarn, npm 최신버전

이런 오류의 원인은 대부분 npm 혹은 yarn 버전과 Node 버전 사이의 이슈 인것 같다.
npm을 사용한다면 update를 해서 최신 버전으로 업데이트 시켜보고

yarn 경우에는

sudo brew upgrade yarn

을 통해 1.22.1로 업그레이드 시켜주었다.

2. @vue/cli 글로벌 설치 시 권한문제

vue 이슈보드에 보니 많은 사람들이 권한 문제인 경우가 많았다.

 #삭제
 sudo npm uninstall -g @vue/cli
 or
 sudo yarn global remove @vue/cli
 
 #재설치
 sudo npm install -g @vue/cli
 or
 sudo yarn global add @vue/cli

우선 삭제하고 재설치를 해본다. 안된다면

sudo npm install -g @vue/cli --unsafe-perm

--unsafe -perm은 관리자 권한으로 실행시켜 주는 명령어 이다.

만약, 권한 문제로 발생한 오류 라면 해결이 된다.

3. xcode 재설치

 /Library/Developer/CommandLineTools/

위 경로에 있는 파일을 삭제해주고

 sudo xcode-select --install

xcode를 다시 설치해준다.

4. core-js 문제

혹시 vue 프로젝트를 생성할 때 babel을 설치하지 않았다면 추가해준다

vue add babel

vue-cli 4 버전에서는 core-js가 3.x 버전으로 업데이트 된 것 같다.

babel이 이미 설치 되어 있다면,

 vue upgrade babel

을 통해서 core-js를 3.x 버전으로 업그레이드 해준다

0개의 댓글