사연

영어 실력이 빈약해서 그런지 간단한 기능같아 보이는데 찾지를 못하고 sourcemap이 되어 있지 않은 scss파일로 작업을 계속 했는데, 아무래도 불편하다고 느껴져서 다시 한 번 찾아보니까 아래와 같이 하면 되는 것이었다.

설치

yarn add @zeit/next-sass node-sass
or
npm install --save @zeit/next-sass node-sass

적용

next.config.js

const withSass = require('@zeit/next-sass')
module.exports = withSass({
  sassLoaderOptions: {
    sourceMap: true
  }
})

끝 ...