error eslint@8.1.0: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "12.18.2" 해결

wkahd01·2021년 11월 1일
1

오류 해결

목록 보기
1/1

오류

프로젝트를 진행하던 도중, pull을 받고 yarn을 통해 패키지를 업데이트하려고 하니, 다음과 같은 오류가 생겼다.

The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "12.18.2"
에러 메세지를 잘 읽어보면, node 버전이 맞지 않아서 발생하는 문제라고 했다.

이를 해결하기 위해, node.js 사이트에서 node.js 최신 LTS 버전을 다운로드해 node 버전을 업그레이드 해주었다.

원래, node.js 업데이트는 명령어를 통해 하려고 했지만, 오류가 나서 찾아봤더니 이러한 경우 공식 사이트에서 최신 버전을 다운로드하면 업데이트가 성공적으로 된다해서 이 방법을 사용했다.

https://jamong-icetea.tistory.com/355 참고

node.js 버전을 업데이트 해준 이후, 다시 실행시켜본 결과 정상적으로 작동함을 확인했다.

오류를 해결하면서..

오류가 어디서부터 나온 문제인지 해결하기 위해 git checkout을 통해 pull을 받기 이전 커밋으로 되돌아가는 과정을 거쳤다.
명령어는 git checkout [커밋 아이디]를 사용했다.

https://velog.io/@janeljs/git-2 참고

다시 최근 커밋으로 돌아가기 위해 아래와 같은 명령어를 사용했다.
git checkout -

문제를 해결하면서 git이 얼마나 유용한지 다시한번 느끼게 되었다.
앞으로, git을 조금 더 다양하게 활용해 보아야겠다.

profile
꾸준하게 공부하기

0개의 댓글