(첫글) Lombok cannot find sybol 오류 해결 방법 (☆버전 에러인 경우★)

woosung_lee·2020년 10월 16일
0

setting

목록 보기
1/1

STS셋팅하는데 lombok설정 중 lombok-1.18.16 설치 에러가 발생했다.
CMD로도 해보고 다 해봤는데 알고보니 1.18.16버전이 최신버전이라 안정화가 안되어 있는 것 같았다.

https://stackoverflow.com/questions/64302892/lombok-creating-gets-and-sets-in-compiled-class-but-not-the-generated-sources-in

위 글을 겨우 발견했다.

After many tries and failures, I could make it work.

This problem is related with this issue.

I've tried to install many different Lombok versions, from 1.18.8 to 1.18.14 failing all the time. To have a last test, I deleted all versions from my .m2 repository and kept only the 1.18.12 version, running the installation again and it worked.

If someone is facing this problem, my suggestion is clear all versions of Lombok from .m2 repository, delete any -javaagent referred to Lombok from eclipse.ini file and make a clean install using 1.18.12 version.

Many thanks to @howlger who helped me a lot and showed me the issue.

한줄 요약하면 1.18.12 버전이 안정적이니 1.18.12 를 사용하라는 뜻이다.. 고마워 스텍오버플로

profile
Full Stack Developer

0개의 댓글