2/13 팀원 도커 설정, 프론트 CI/CD 설정

AI·2026년 2월 13일

ec2 변경 및 로컬 mysql 연동

ec2 t3.medium로 변경

rds 설정한거 로컬에서 확인하기 hostname은 RDS_HOST로 썼던 값 쓰고 username, pw도 RDS_USERNAME, RDS_PASSWORD썼던 값을 작성하고 test connection해서 다음과 같이 뜨면 성공이다

트러블 슈팅

docker ps -a 해도, 키바나는 안뜸

$ sudo docker-compose up -d kibana
$ sudo docker-compose logs -f kibana

하면 되기는 함. 하지만 그냥 입력하면 안됨

$ sudo docker-compose logs -f kibana
WARN[0000] /home/ubuntu/docker-compose.yml: the attribute `version` is obsolete, it will be ignored, please remove it to avoid potential confusion

$ docker stats kibana
Error response from daemon: No such container: kibana

$ curl -I http://localhost:9200
curl: (56) Recv failure: Connection reset by peer

=> 용량 문제, 엘라스틱 서치가 제대로 작동을 안한다는 것을 알 수 있음
파일을 home에 작성하여 파일 위치 이동

sudo mv /home/ubuntu/docker-compose.yml /home/ubuntu/project/docker-compose.yml
$ docker logs --tail 50 elasticsearch

"error.message":"failed to obtain node locks, tried [/usr/share/elasticsearch/data]; 
maybe these locations are not writable or multiple nodes were started on the same data path?"

=> 권한 문제

# 데이터 폴더 권한을 모든 사용자(도커 포함)에게 허용
sudo chmod -R 777 ./es_data

# 꼬여있는 잠금 파일이 있다면 삭제
sudo rm -rf ./es_data/nodes

# 전체 서비스 다시 시작 (처음 한 번만 수동으로 띄우기)
sudo docker-compose up -d

다시 down하고 진행하니 성공!

추가) 리소스 확인법

free -h

IAM 사용자 만들기

선택한 2개가 잘 들어가있는지 확인하면 된다

만들어진 생성자의 상세정보로 들어온다

저장해두기

GitHub Secrets 추가

AWS_ACCESS_KEY_ID: (방금 복사한 액세스 키)
AWS_SECRET_ACCESS_KEY: (방금 복사한 비밀 액세스 키)
AWS_REGION: ap-northeast-2 (서울 리전 기준)
S3_BUCKET_NAME: (프론트엔드용으로 미리 만들어둔 S3 버킷 이름)

s3 지역 설정


보니까 미국으로 되어있음 ㅎㅎ

그래서 버킷을 지우고 다시 지역 설정하려고 하는데 위 사진처럼 변경이 안됨

상단에서 서울로 설정을 해야 함

그럼 서울로 잘 들어가 있는 것을 확인할 수 있음

버킷 이름을 유지해야 하는 경우에는 버킷을 삭제하지 마세요. 대신 버킷을 비우세요.
https://repost.aws/ko/knowledge-center/s3-conflicting-conditional-operation
이걸 모르고 지워서 다른 이름으로 버킷을 만들었다 ㅠㅠ

S3의 속성 -> 정적 웹 사이트 호스팅 -> 버킷 웹 사이트 엔드포인트로 들어가서 보면

잘 동작함을 알 수 있다.

버킷 비우기를 통해 로컬에서 개발을 30% 이상 정도 진행한 후에 다시 키고자한다.

0개의 댓글