[JavaScript] 2562 | 백준

유인학·2022년 5월 18일
0

[JS] Algorithm(백준)

목록 보기
37/82
post-thumbnail

📄 문제

9개의 서로 다른 자연수가 주어질 때,
이들 중 최댓값을 찾고 그 최댓값이 몇 번째 수인지를 구하는 프로그램을 작성하시오.

예를 들어, 서로 다른 9개의 자연수

3, 29, 38, 12, 57, 74, 40, 85, 61

이 주어지면, 이들 중 최댓값은 85이고, 이 값은 8번째 수이다.

⌨ 예제 입력

3
29
38
12
57
74
40
85
61

📺 예제 출력

85
8

🚩solution

const input = require('fs').readFileSync('/dev/stdin').toString().split('\n');
let max = 0;
let i;
input.map((value, index) => {
  if (Number(value > max)) {
    max = Number(value);
    i = index;
  }
});
console.log(`${max}\n${i + 1}`);
profile
'유'발자!

0개의 댓글