CocoaPods could not find compatible versions for pod "cloud_firestore":

geebab·2021년 8월 5일
0

flutter에서 firestore dependency 설치 후 iOS build시 error.

Podfile.lock을 지우고 어쩌고 많은데..

다 잘 안된다.

1) 걍 새로운 프로젝트 만들고
2) yaml file에 디펜덴시 적어주고
3) 터미널에 flutter pub get
4) ./ios 에서 터미널에서 pod install 후 에러가 한번 남.
5) 4)에서 생성된 Podfile 오픈 -> 최상단에

#Uncomment this line to define a global platform for your project
platform :ios, '11.0'
으로 변경

6) 터미널에서 pod install 실행
7) 새로운 프로젝트에 lib file 복사
8) 나머지ㅠ 파이어베이스와 연결 json, plist file copy 등등..

profile
Flutter 열심히 파보고 있습니다만 연장이 썩 좋지 않네요ㅠ

0개의 댓글