[백준]-DFS와 BFS

이정연·2022년 10월 14일
0

CodingTest

목록 보기
12/165

DFS와 BFS

solved_ac[Class3][DFS와 BFS](https://www.acmicpc.net/problem/1260)

문제

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.

입력

첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.

출력

첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.

  • 예제 입력 1
4 5 1
1 2
1 3
1 4
2 4
3 4
  • 예제 출력 1
1 2 4 3
1 2 3 4
  • 예제 입력 2
5 5 3
5 4
5 2
1 2
3 4
3 1
  • 예제 출력 2
3 1 2 5 4
3 1 4 2 5
  • 예제 입력 3
1000 1 1000
999 1000
  • 예제 출력 3
1000 999
1000 999

CODE

1트 (오답)

import sys
from collections import deque
input = sys.stdin.readline

# 초기 조건
node,edge,start = map(int,input().split())
graph = [[] for _ in range(node+1)]
for _ in range(edge):
    a,b = map(int,input().split())
    graph[a].append(b)
    graph[b].append(a)
for i in range(node+1):
    graph[i].sort()
visited = [0]*(node+1)

def get_next_node(visited,cur_node):
    for i in graph[cur_node]:
        if visited[i] == 0:
            return i
    return False

dfs_path = []
# DFS
def dfs(start):
    dfs_path.append(start)
    visited[start] = 1
    next_node = get_next_node(visited,start)

    if next_node:
        dfs(next_node)

# BFS
def bfs(start):
    bfs_path = []
    q = deque([start])
    visited[start] = 1
    while q:
        cur_node = q.popleft()
        bfs_path.append(cur_node)

        for i in graph[cur_node]:
            if visited[i] == 0:
                q.append(i)
                visited[i] = 1
    return bfs_path

dfs(start)
print(*dfs_path)
visited = [0]*(node+1)
print(*bfs(start))

아직 이 코드가 왜 틀린지 잘 모르겠다. 예제 입력은 다 출력이 되는데 반례를 못 찾겠다.

get_next_node를 통해 가장 작은 번호의 노드 순서대로 DFS를 실행하였고

외부 dfs_path 리스트를 업데이팅 하는 방식으로 DFS 방문 순서를 찍었다.(왜냐하면 DFS는 재귀방식이기 때문에 함수 내부에서 리스트를 생성하면 리스트 업데이팅이 안된다.)

그리고 BFS는 함수 내부에서 리스트를 생성하여 방문 순서를 찍은 후 이를 return 해주었다.

  • 함수 get_next_node 설명

    1.작은 노드의 번호 순서대로 탐색해야 하기 때문에 초기 조건에서 리스트를 오름차순 정렬 시켜주었다.

    2.따라서 현재노드와 연결되어 있는 노드들 중 아직 방문하지 않은 노드를 순차적으로 찾는다면 그것이 곧 문제 조건에 맞는 다음 노드가 된다.

    3.만일 현재노드와 연결되어 있는 모든 노드를 탐색해보았는데 전부 방문하였으면 더 이상 탐색할 노드가 없으므로 False를 return 한다.

  • for문 대체
    블로그를 포스팅하면서 다시 생각해보니 굳이 함수 사용을 하지 않고 함수 안에 바로 넣어주는 것이 더욱 직관적인 것 같다. 변화 내용은 2트 코드에서 확인

2트 (정답)

import sys
from collections import deque
input = sys.stdin.readline

# 초기 조건
node,edge,start = map(int,input().split())
graph = [[] for _ in range(node+1)]
for _ in range(edge):
    a,b = map(int,input().split())
    graph[a].append(b)
    graph[b].append(a)
for i in range(node+1):
    graph[i].sort()
visited = [0]*(node+1)

def get_next_node(visited,cur_node):
    for i in graph[cur_node]:
        if visited[i] == 0:
            return i
    return False

# DFS
def dfs(start):
    print(start,end=" ")
    visited[start] = 1

    for next_node in graph[start]:
        if visited[next_node] == 0:
            dfs(next_node)

# BFS
def bfs(start):
    q = deque([start])
    visited[start] = 1
    while q:
        cur_node = q.popleft()
        print(cur_node, end=" ")

        for next_node in graph[cur_node]:
            if visited[next_node] == 0:
                q.append(next_node)
                visited[next_node] = 1

dfs(start)
print()
visited=[0]*(node+1)
bfs(start)

배열을 사용하지 않고 함수 내부에서 print를 이용하여 즉각적으로 찍어주었다.

profile
0x68656C6C6F21

0개의 댓글