77 격자판 미로를 탈출하는 최단경로의 길이를 출력하는 프로그램을 작성하세요. 경로의 길
이는 출발점에서 도착점까지 가는데 이동한 횟수를 의미한다. 출발점은 격자의 (1, 1) 좌표이
고, 탈출 도착점은 (7, 7)좌표이다. 격자판의 1은 벽이고, 0은 도로이다.
격자판의 움직임은 상하좌우로만 움직인다. 미로가 다음과 같다면
위와 같은 경로가 최단 경로의 길이는 12이다.
▣ 입력설명
첫 번째 줄부터 77 격자의 정보가 주어집니다.
▣ 출력설명
첫 번째 줄에 최단으로 움직인 칸의 수를 출력한다. 도착할 수 없으면 -1를 출력한다.
▣ 입력예제 1
0 0 0 0 0 0 0
0 1 1 1 1 1 0
0 0 0 1 0 0 0
1 1 0 1 0 1 1
1 1 0 1 0 0 0
1 0 0 0 1 0 0
1 0 1 0 0 0 0
▣ 출력예제 1
12
import java.util.*;
class Point{
public int x, y;
Point(int x, int y){
this.x = x;
this.y = y;
}
}
class Main{
// 이동할 네 가지 방향 정의 (상, 우, 하, 좌)
static int[] dx = {-1, 0, 1, 0};
static int[] dy = {0, 1, 0, -1};
static int[][] board, dis;
public void BFS(int x, int y){
Queue<Point> queue = new LinkedList<>();
queue.offer(new Point(x, y));
// 출발점 방문 체크 (재방문 하지 않기 위해)
board[x][y] = 1;
while(!queue.isEmpty()){
Point cv = queue.poll();
for(int i=0; i<4; i++){
int nx = cv.x + dx[i];
int ny = cv.y + dy[i];
if(nx>=1&&nx<=7&&ny>=1&&ny<=7 && board[nx][ny]==0){
// 방문 체크 (재방문 하지 않기 위해)
board[nx][ny]=1;
queue.offer(new Point(nx, ny));
dis[nx][ny] = dis[cv.x][cv.y]+1;
}
}
}
}
public static void main(String[] args){
Main T = new Main();
Scanner kb = new Scanner(System.in);
board = new int[8][8];
dis = new int[8][8];
for(int i=1; i<=7; i++){
for(int j=1; j<=7; j++){
board[i][j] = kb.nextInt();
}
}
T.BFS(1,1);
// 벽 때문에 도착점에 도달한 적 없는 경우
if(dis[7][7]==0) System.out.println(-1);
// 최단거리
else System.out.println(dis[7][7]);
}
}