boj 13913 숨바꼭질4(bfs) Java

강민승·2023년 5월 31일
0

알고리즘

목록 보기
3/19
post-thumbnail

문제

수빈이는 동생과 숨바꼭질을 하고 있다. 수빈이는 현재 점 N(0 ≤ N ≤ 100,000)에 있고, 동생은 점 K(0 ≤ K ≤ 100,000)에 있다. 수빈이는 걷거나 순간이동을 할 수 있다. 만약, 수빈이의 위치가 X일 때 걷는다면 1초 후에 X-1 또는 X+1로 이동하게 된다. 순간이동을 하는 경우에는 1초 후에 2*X의 위치로 이동하게 된다.

수빈이와 동생의 위치가 주어졌을 때, 수빈이가 동생을 찾을 수 있는 가장 빠른 시간이 몇 초 후인지 구하는 프로그램을 작성하시오.

입력

첫 번째 줄에 수빈이가 있는 위치 N과 동생이 있는 위치 K가 주어진다. N과 K는 정수이다.

출력

첫째 줄에 수빈이가 동생을 찾는 가장 빠른 시간을 출력한다.

둘째 줄에 어떻게 이동해야 하는지 공백으로 구분해 출력한다.

예제 입력 1

5 17

예제 출력 1

4
5 10 9 18 17

예제 입력 2

5 17

예제 출력 2

4
5 4 8 16 17

이걸 풀 때, 최단거리는 bfs지만 dfs로 풀고싶었다. 재귀 돌리면 풀릴 것 같았다...
하지만..? 시간초과 ㅋㅋㅋㅋㅋㅋㅋㅋㅋㅋ 최단거리는 bfs구나..
이렇게 접근하면 안되는데.. 시간 복잡도도 제대로 계산 안하고 느낌대로 풀어버림.
어떻게 풀지 고민하고 생각하는 시간을 더 많이 갖자.

import java.util.*;
import java.io.*;

public class Main {
    static class Node {
        int index, count;
        ArrayList<Integer> path;

        Node(int index, int count, ArrayList<Integer> path) {
            this.index = index;  // 현재 위치
            this.count = count;  // 이동 횟수
            this.path = path;  // 현재까지의 경로
        }
    }

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        int N = Integer.parseInt(input[0]);  
        int K = Integer.parseInt(input[1]);  
        Queue<Node> queue = new LinkedList<>();  // BFS를 위한 큐
        boolean[] visited = new boolean[100001];  // 방문 여부를 저장하는 배열

        // 시작 위치를 경로에 추가하고 큐에 넣음
        ArrayList<Integer> startPath = new ArrayList<>();
        startPath.add(N);
        queue.add(new Node(N, 0, startPath));
        visited[N] = true;  // 시작 위치를 방문했다고 표시

        // BFS 시작
        while (!queue.isEmpty()) {
            Node node = queue.poll();  // 큐에서 노드를 하나 뽑음
            int index = node.index;  // 현재 위치
            int count = node.count;  // 이동 횟수
            ArrayList<Integer> path = node.path;  // 현재까지의 경로

            // 목표 위치에 도달한 경우
            if (index == K) {
                System.out.println(count);  // 이동 횟수 출력
                // 경로 출력
                for (int i : path) {
                    System.out.print(i + " ");
                }
                return;
            }

            // 다음 위치를 큐에 넣음 (현재 위치에서 -1, +1, *2 이동)
            if (index - 1 >= 0 && !visited[index - 1]) {
                visited[index - 1] = true;  // 다음 위치를 방문했다고 표시
                ArrayList<Integer> newPath = new ArrayList<>(path);
                newPath.add(index - 1);  // 다음 위치를 경로에 추가
                queue.add(new Node(index - 1, count + 1, newPath));  // 큐에 넣음
            }
            if (index + 1 <= 100000 && !visited[index + 1]) {
                visited[index + 1] = true;
                ArrayList<Integer> newPath = new ArrayList<>(path);
                newPath.add(index + 1);
                queue.add(new Node(index + 1, count + 1, newPath));
            }
            if (index * 2 <= 100000 && !visited[index * 2]) {
                visited[index * 2] = true;
                ArrayList<Integer> newPath = new ArrayList<>(path);
                newPath.add(index * 2);
                queue.add(new Node(index * 2, count + 1, newPath));
            }
        }
    }
}

profile
Step by Step goes a long way. 꾸준하게 성장하는 개발자 강민승입니다.

0개의 댓글