jest-worker@27.0.0-next.5: The engine "node" is incompatible with this module. Expected version "^10.13.0 || ^12.13.0 || ^14.15.0 || >=15.0.0". Got "14.8.0"

kusdsuna·2021년 11월 19일
0

에러핸들링

목록 보기
3/3

Next.js에서 typescript버전 styled-components를 설치하는 와중에 에러가 발생했다.

해당 에러는 Node.js에 버전이 달라서 생기는 에러이기에 Node.js 버전을 바꿔주면 해결됩니다.

아래 명령어로 설치해준뒤

nvm install 14.15.0

14.15.0 버전으로 변경해주면됩니다.

nvm use 14.15.0
profile
블로그 이전중입니다 => https://kusdsuna.tistory.com/

0개의 댓글