Error running pod install - Flutter

kyleryu·2021년 6월 22일
7

Flutter

목록 보기
1/1
post-thumbnail

문제 발생

Error running pod install
Error launching application on iPhone 12 Pro Max.

즐겁게 플러터 개발을 하고 있는 와중에 디버깅을 하니 이런 에러가 뜬다.😭

ㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡ

해결 방법

방법 1

구글에 'Error running pod install'치면 나오는 스택오버플로우 답변을
다 시도해봐도 안 되는 분들은 이 방법을 시도해보면 나처럼 해결될 것 같다.

ios폴더 pod파일 상단에 이런 주석이 되어있다.

# platform :ios, '9.0'

콘솔창에 나와 있는 에러 내용을 자세히 보면 임의로 버전을 9.0으로 맞춰놨다고 되어있다.

이 부분을

# platform :ios, '11.0'

라고 바꿔주자. 그렇다... 숫자 하나 차이다.😂

방법 2

사실 이게 핵심인 것 같다.
필자는 이번에 M1 맥북으로 기종을 변환했는데
M1 맥북 이용자 중에서 유독 pod install 이슈가 많이 보인다.
그래서 M1 출시 이전에 제시되었던 해결책이 먹히지 않았던 것 같다.

터미널에

sudo arch -x86_64 gem install ffi

그리고

arch -x86_64 pod install

를 입력 후 다시 빌드해보자.

계속
Running pod install...
만 주구장창 뜨던 것과 다르게

Running Xcode build...
가 뜨는 순간
"어... 설마?"싶을 것이고

Xcode build done.
이 순간
"와!"라고 외칠 것이다.🤣

ㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡ

돌아보기

꼬박 4시간을 쏟아부었다.
구글링과 스택오버플로우에 제시된 온갖 해결책을 시도해봐도 풀리지 않았다.
(이쯤 되면 딱 해결될 법도 싶었고 생각보다 간단한 문제라고 생각했는데!)

예상한 것보다 길어지는 싸움에 샤워하면서도 해결책을 고민했다.

그래도 해결하니 보람차다.
다시 즐겁게 빌드하며 플러터 개발을 할 수 있으니 말이다!😀

profile
한 걸음

10개의 댓글

comment-user-thumbnail
2021년 12월 31일

덕분에 문제를 쉽게 해결 할 수 있었네요 감사합니다!

1개의 답글
comment-user-thumbnail
2022년 3월 7일

감사합니다!!

1개의 답글
comment-user-thumbnail
2022년 3월 16일

사랑합니다 카일님 덕분에 빠른 문제해결 했습니다,,,

1개의 답글
comment-user-thumbnail
2022년 3월 25일

두번째껀 안되고 첫번째꺼만 적용됐는데 해결됐네요.
감사합니다!!

1개의 답글
comment-user-thumbnail
2022년 4월 8일

덕분에 해결했습니다 감사합니다 ㅠㅠ

1개의 답글