EIGRP

이기태·2024년 5월 2일
0

CCNA

목록 보기
13/17

EIGRP

- Advance Distance Vactor
- Split-horizon
- no auto-summary
- 변화된 내용이 있을 때만 라우팅 업데이트 실시
- 매트릭: Bandwidth, Deply 기반 계산
[참고] IGRP 프로토콜 특징
- Distance Vactor
- 90초마다 주기적인 라우팅 업데이트
- 매트릭: Bandwidth, Deply 기반 계산

EIGRP 설정

@R1,R3
conf t
router eigrp 100
no auto-summary
network 13.0.0.0
network 172.16.0.0
passive-interface f0/0
passive-interface lo172
end

@R2 
conf t
router eigrp 100
no auro-summary
network 13.0.0.0
passive-interface f0/0
end

// 확인(R1,R2,R3)
sh ip eigrp neighbors
sh ip route
	D: eigrp

클래스리스 라우팅 프로토콜(Classless Routing Protocol)

- VLSM 0, CIDR(Classless Inter-Domain Routing) 0
- no auro-summary
- 수동 요약 기능 지원
[참고] RIPv2 vs EIGRP

  • RIPv2: VLSM 0, CIER X
  • EIGRP: VLSM 0, CIER 0

수동 요약 실습

@R1
conf t
int lo 8
ip addr 128.28.8.1 255.255.255.0
int lo 9
ip addr 128.28.9.1 255.255.255.0
int lo 10
ip addr 128.28.10.1 255.255.255.0
int lo 11
ip addr 128.28.11.1 255.255.255.0
int lo 12
ip addr 128.28.12.1 255.255.255.0

router eigrp 100
network 128.28.0.0
passive-interface lo8
passive-interface lo9
passive-interface lo10
passive-interface lo11
passive-interface lo12
end
!
sh ip int br

@R1,R2,R3
sh ip route eigrp

128.28.8.0
128.28.9.0
128.28.10.0
128.28.11.0
128.28.12.0
----------------
128.28.00001 000.0
128.28.00001 001.0
128.28.00001 010.0
128.28.00001 011.0
128.28.00001 100.0
----------------> 128.28.8.0/21
255.255.11111 000.0 <- 255.255.248.0 <- /21

@R2
conf t
int s1/0
ip summary-address eigrp 100 128.28.8.0 255.255.248.0
end

@R2,R3
sh ip route eigrp

MD5 해시 함수를 이용한 인증 기능

@R1
conf t
key chain EIGRP_K
key 13
key-string cisco
int s1/0
ip authentication key-chain eigrp 100 EIGRP_K
ip authentication mode eigrp 100 md5
end

@R2
conf t
key chain EIGRP_K
key 13
key-string cisco
int s1/0
ip authentication key-chain eigrp 100 EIGRP_K
ip authentication mode eigrp 100 md5
end

@R2,R1
sh ip eigrp neighbors
sh ip route

EIGRP 패킷 유형

// neighbor 관계 성립 과정
R1(s1/0) -----------------(s1/1)R2
13.13.12.1 -> 224.0.0.10
hello(AS, K상수) ->
				<- hello(AS, K상수)
update(R1)->
						<- ack

// 네트워크 장애
NET장애: R1(s1/0)
		R1(s1/0) -----------------(s1/1)R2
		query ->
								<- ack
		ack ->
								<- reply

// neighbor 관계 유지

균등/비균등 부하 분산(Dual Algorithms)

파일: 8-3.EIGRP 균등 & 비균등 로드 분산.pkg

@R1,R3
conf t
router eigrp 100
no auto-summary
network 13.0.0.0
end

@R2,R4
conf t
router eigrp 100
no auto-summary
network 13.0.0.0
passive-interface f0/0
end

@R1,R2,R3,R4
sh ip eigrp neighbors
sh ip route
sh ip eigrp topology
----------------------------------------
IP-EIGRP Topology Table for AS 100/ID(13.13.40.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 13.13.12.0/24, 1 successors, FD is 2681856
         via 13.13.14.1 (2681856/2169856), Serial1/0   // FD/AD
P 13.13.14.0/24, 1 successors, FD is 2169856
         via Connected, Serial1/0
P 13.13.20.0/24, 2 successors, FD is 2684416
         via 13.13.14.1 (2684416/2172416), Serial1/0
         via 13.13.34.3 (2684416/2172416), Serial1/1
P 13.13.23.0/24, 1 successors, FD is 2681856
         via 13.13.34.3 (2681856/2169856), Serial1/1
P 13.13.34.0/24, 1 successors, FD is 2169856
         via Connected, Serial1/1
P 13.13.40.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0         
----------------------------------------
  • 균등 부하분산
  1. 최적경로: FD메트릭이 가장 작은 경로
  2. 후속경로: FD > AD가 작은 경로, FD <= AD이면 후속경로가 되지 않음.
  • 비균등 부하분산
@R2
sh int s1/0
Serial1/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 13.13.12.1/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,          -> BW,DLY값 중요
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
-------------------------------------------------------------------------
conf t
int s1/0
bandwidth 2048
end

@R3
conf t
int s1/0
bandwidth 2048
int s1/1
bandwidth 2048
end

@R4
conf t
int s1/1
bandwidth 2048
end

------------------------
router eigrp 100
variance 2 Å 범위 1~128 
------------------------

EIGRP 매트릭


  • EIGRP 네이버 성립 조건
    인접 라우터와 AS값과 K상수값이 같아야 한다.
    K상수는 디폴트로 되어있기때문에 AS값만 맞추면 된다.

패킷 유형

Hello 패킷
Update 패킷
Query 패킷
Reply 패킷
Ack 패킷

EIGRP 경로 유형

경로 유형
- 내부 경로(Internal Route): D
- 외부 경로(External Route): D EX

R1(s1/0)--------------------(s1/1)R3(lo #)
						lo 11: 100.100.1.1/24
                        lo 12: 100.100.2.1/24
                        lo 13: 100.100.3.1/24


@R3
conf t
int lo 11
ip addr 100.100.1.1 255.255.255.0
int lo 12
ip addr 100.100.2.1 255.255.255.0
int lo 13
ip addr 100.100.3.1 255.255.255.0
!
router rip
version 2
no auto-summary
network 100.0.0.0
!
router eigrp 100
redistribute rip metric 1544 20000 255 1 1500
end
	[참고] redistribute rip metric 1544 20000 255 1 1500
    * rip: rip -> eigrp
    * 1544 -> BW
    * 20000 -> Delay
    * 255 -> 신뢰도
    * 1 -> load
    * 1500 -> MTU

@R1
sh ip route

D EX    100.100.1.0 [170/7801856] via 13.13.12.2, 00:00:09, Serial1/0
D EX    100.100.2.0 [170/7801856] via 13.13.12.2, 00:00:09, Serial1/0
D EX    100.100.3.0 [170/7801856] via 13.13.12.2, 00:00:09, Serial1/0
     133.133.0.0/24 is subnetted, 1 subnets
-> 외부 경로

EIGRP 정보 확인

sh ip protocols

sh ip eigrp neighbors

sh ip eigrp topology

sh ip route
sh ip route eigrp
sh ip route 128.28.0.0

sh ip eigrp traffic

debug ip packet
debug ip packet detail
debug eigrp packets
debug eigrp packets hello
debug eigrp packets update ack
debug eigrp packets query reply ack

no debug ip packet
undebug all (un all)

0개의 댓글

관련 채용 정보