[백준]#11000 강의실 배정

SeungBird·2021년 4월 10일
0

⌨알고리즘(백준)

목록 보기
308/401

문제

수강신청의 마스터 김종혜 선생님에게 새로운 과제가 주어졌다.

김종혜 선생님한테는 Si에 시작해서 Ti에 끝나는 N개의 수업이 주어지는데, 최소의 강의실을 사용해서 모든 수업을 가능하게 해야 한다.

참고로, 수업이 끝난 직후에 다음 수업을 시작할 수 있다. (즉, Ti ≤ Sj 일 경우 i 수업과 j 수업은 같이 들을 수 있다.)

수강신청 대충한 게 찔리면, 선생님을 도와드리자!

입력

첫 번째 줄에 N이 주어진다. (1 ≤ N ≤ 200,000)

이후 N개의 줄에 Si, Ti가 주어진다. (1 ≤ Si < Ti ≤ 109)

출력

강의실의 개수를 출력하라.

제한

  • 1 ≤ N, M ≤ 10
  • 3 ≤ N×M ≤ 100
  • 2 ≤ 섬의 개수 ≤ 6

예제 입력 1

3
1 3
2 4
3 5

예제 출력 1

2

풀이

이 문제는 우선순위 큐를 이용한 min_heap을 구현해서 풀 수 있었다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.PriorityQueue;

public class Main {

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int N = Integer.parseInt(br.readLine());
        PriorityQueue<Integer> heap1 = new PriorityQueue<>();
        PriorityQueue<Pair> heap2 = new PriorityQueue<>();

        for(int i=0; i<N; i++) {
            String[] input = br.readLine().split(" ");
            heap2.add(new Pair(Integer.parseInt(input[0]), Integer.parseInt(input[1])));
        }

        int ans = 0;
        while(!heap2.isEmpty()) {
            ans = Math.max(ans, heap1.size());

            if(heap1.isEmpty()) {
                heap1.add(heap2.poll().t);
            }

            else {
                if(heap2.peek().s>=heap1.peek())
                    heap1.poll();

                else
                    heap1.add(heap2.poll().t);
            }
        }

        System.out.println(ans);
    }

    public static class Pair implements Comparable<Pair>{
        int s;
        int t;

        public Pair (int s, int t) {
            this.s = s;
            this.t = t;
        }

        public int compareTo(Pair p) {
            return this.s > p.s ? 1 : -1;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글