[백준]#11657 타임머신

SeungBird·2020년 10월 22일
0

⌨알고리즘(백준)

목록 보기
214/401

문제

N개의 도시가 있다. 그리고 한 도시에서 출발하여 다른 도시에 도착하는 버스가 M개 있다. 각 버스는 A, B, C로 나타낼 수 있는데, A는 시작도시, B는 도착도시, C는 버스를 타고 이동하는데 걸리는 시간이다. 시간 C가 양수가 아닌 경우가 있다. C = 0인 경우는 순간 이동을 하는 경우, C < 0인 경우는 타임머신으로 시간을 되돌아가는 경우이다.

1번 도시에서 출발해서 나머지 도시로 가는 가장 빠른 시간을 구하는 프로그램을 작성하시오.

입력

첫째 줄에 도시의 개수 N (1 ≤ N ≤ 500), 버스 노선의 개수 M (1 ≤ M ≤ 6,000)이 주어진다. 둘째 줄부터 M개의 줄에는 버스 노선의 정보 A, B, C (1 ≤ A, B ≤ N, -10,000 ≤ C ≤ 10,000)가 주어진다.

출력

만약 1번 도시에서 출발해 어떤 도시로 가는 과정에서 시간을 무한히 오래 전으로 되돌릴 수 있다면 첫째 줄에 -1을 출력한다. 그렇지 않다면 N-1개 줄에 걸쳐 각 줄에 1번 도시에서 출발해 2번 도시, 3번 도시, ..., N번 도시로 가는 가장 빠른 시간을 순서대로 출력한다. 만약 해당 도시로 가는 경로가 없다면 대신 -1을 출력한다.

예제 입력 1

3 4
1 2 4
1 3 3
2 3 -1
3 1 -2

예제 출력 1

4
3

예제 입력 2

3 4
1 2 4
1 3 3
2 3 -4
3 1 -2

예제 출력 2

-1

예제 입력 3

3 2
1 2 4
1 2 3

예제 출력 3

3
-1

풀이

이 문제는 벨만-포드 알고리즘을 이용해서 풀 수 있었다. 벨만포드의 경우 max 값을 유효한 값으로 설정해야 오버플로우를 피할 수 있다.

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    static int max = Integer.MAX_VALUE-10000;

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        int N = Integer.parseInt(input[0]);
        int M = Integer.parseInt(input[1]);
        long[] len = new long[N+1];
        Pair[] edge = new Pair[M];
        for(int i=0; i<=N; i++) {
            len[i] = max;
        }
        len[1] = 0;

        for(int i=0; i<M; i++) {
            input = br.readLine().split(" ");
            int start = Integer.parseInt(input[0]);
            int end = Integer.parseInt(input[1]);
            int cost = Integer.parseInt(input[2]);

            edge[i] = new Pair(start, end, cost);
        }

        for(int i=0; i<N-1; i++) {
            for(int j=0; j<M; j++) {
                if(len[edge[j].start]==max) continue;

                if(len[edge[j].end] > len[edge[j].start]+edge[j].cost)
                    len[edge[j].end] = len[edge[j].start]+edge[j].cost;
            }
        }

        boolean flag = false;
        for(int j=0; j<M; j++) {
            if(len[edge[j].start]==max) continue;

            if(len[edge[j].end] > len[edge[j].start]+edge[j].cost) {
                flag = true;
                break;
            }
        }

        if(flag)
            System.out.println(-1);

        else {
            for(int i=2; i<=N; i++) {
                if(len[i]==max)
                    System.out.println(-1);
                else
                    System.out.println(len[i]);
            }
        }
    }

    public static class Pair {
        int start;
        int end;
        int cost;

        public Pair(int start, int end, int cost) {
            this.start = start;
            this.end = end;
            this.cost = cost;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글