[백준]#1260 DFS와 BFS

SeungBird·2020년 8월 26일
0

⌨알고리즘(백준)

목록 보기
44/401

문제

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.

입력

첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.

출력

첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.

예제 입력 1

4 5 1
1 2
1 3
1 4
2 4
3 4

예제 출력 1

1 2 4 3
1 2 3 4

예제 입력 2

5 5 3
5 4
5 2
1 2
3 4
3 1

예제 출력 2

3 1 2 5 4
3 1 4 2 5

예제 입력 3

1000 1 1000
999 1000

예제 출력 3

1000 999
1000 999

풀이

이 문제는 DFS와 BFS 알고리즘을 잘 이해하고 있다면 쉽게 풀수 있다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int N;
    static boolean[] visited;
    static ArrayList<Integer> result = new ArrayList<>();
    static int[][] map;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] str = br.readLine().split(" ");
        N = Integer.parseInt(str[0]);
        int M = Integer.parseInt(str[1]);
        int V = Integer.parseInt(str[2]);
        map = new int[N+1][N+1];

        for(int i=0; i<M; i++) {
            String[] input = br.readLine().split(" ");
            map[Integer.parseInt(input[0])][Integer.parseInt(input[1])]=1;
            map[Integer.parseInt(input[1])][Integer.parseInt(input[0])]=1;
        }

        visited = new boolean[N+1];
        DFS(V);

        while(!result.isEmpty()) {
            if(result.size()==1)
                System.out.println(result.remove(0));
            else
                System.out.print(result.remove(0)+" ");
        }

        visited = new boolean[N+1];
        BFS(V);

        while(!result.isEmpty()) {
            if(result.size()==1)
                System.out.print(result.remove(0));
            else
                System.out.print(result.remove(0)+" ");
        }
    }

    static void DFS(int v) {
        visited[v] = true;
        result.add(v);

        for(int i=1; i<=N; i++) {
            if(map[v][i]==1 && !visited[i]) {
                DFS(i);
            }
        }
    }

    static void BFS(int v) {
        Queue<Integer> queue = new LinkedList<>();
        queue.add(v);
        visited[v] = true;
        result.add(v);

        while(!queue.isEmpty()) {
            int current = queue.poll();

            for (int i = 1; i <= N; i++) {
                if (map[current][i] == 1 && !visited[i]) {
                    visited[i] = true;
                    result.add(i);
                    queue.add(i);
                }
            }
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글