[백준]#1916 최소비용 구하기

SeungBird·2020년 8월 27일
0

⌨알고리즘(백준)

목록 보기
78/401

문제

N개의 도시가 있다. 그리고 한 도시에서 출발하여 다른 도시에 도착하는 M개의 버스가 있다. 우리는 A번째 도시에서 B번째 도시까지 가는데 드는 버스 비용을 최소화 시키려고 한다. A번째 도시에서 B번째 도시까지 가는데 드는 최소비용을 출력하여라. 도시의 번호는 1부터 N까지이다.

입력

첫째 줄에 도시의 개수 N(1 ≤ N ≤ 1,000)이 주어지고 둘째 줄에는 버스의 개수 M(1 ≤ M ≤ 100,000)이 주어진다. 그리고 셋째 줄부터 M+2줄까지 다음과 같은 버스의 정보가 주어진다. 먼저 처음에는 그 버스의 출발 도시의 번호가 주어진다. 그리고 그 다음에는 도착지의 도시 번호가 주어지고 또 그 버스 비용이 주어진다. 버스 비용은 0보다 크거나 같고, 100,000보다 작은 정수이다.

그리고 M+3째 줄에는 우리가 구하고자 하는 구간 출발점의 도시번호와 도착점의 도시번호가 주어진다. 출발점에서 도착점을 갈 수 있는 경우만 입력으로 주어진다.

출력

첫째 줄에 출발 도시에서 도착 도시까지 가는데 드는 최소 비용을 출력한다.

예제 입력 1

5
8
1 2 2
1 3 3
1 4 1
1 5 10
2 4 2
3 4 1
3 5 1
4 5 3
1 5

예제 출력 1

4

풀이

이 문제는 다익스트라 알고리즘을 이용해서 풀었다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    static int N;
    static int[][] graph;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        N = Integer.parseInt(br.readLine());
        int M = Integer.parseInt(br.readLine());
        graph = new int[N+1][N+1];

        for(int i=1; i<=N; i++) {
            for(int j=1; j<=N; j++) {
                graph[i][j]=-1;
            }
        }

        for(int i=0; i<M; i++) {
            String[] input = br.readLine().split(" ");
            int start = Integer.parseInt(input[0]);
            int end = Integer.parseInt(input[1]);
            int cost = Integer.parseInt(input[2]);

            if(graph[start][end]==-1)
                graph[start][end] = cost;

            else {
                if(graph[start][end]>cost)
                    graph[start][end]=cost;
            }
        }

        String[] input = br.readLine().split(" ");
        int start = Integer.parseInt(input[0]);
        int end = Integer.parseInt(input[1]);

        int[] length = dijkstra(start);
        System.out.println(length[end]);
    }

    static int[] dijkstra(int v){
        int distance[] = new int[N+1];
        boolean[] check = new boolean[N+1];

        for(int i=1; i<=N; i++){
            distance[i] = Integer.MAX_VALUE;
        }

        distance[v] = 0;
        check[v] = true;

        for(int i=1; i<=N; i++){
            if(!check[i] && graph[v][i]!=-1){
                distance[i] = graph[v][i];
            }
        }

        for(int i=0; i<N-1; i++){
            int min = Integer.MAX_VALUE;
            int min_index = 0;

            for(int j=1; j<=N; j++){
                if(!check[j] && distance[j]!=Integer.MAX_VALUE){
                    if(distance[j]<min ){
                        min=distance[j];
                        min_index = j;
                    }
                }
            }

            check[min_index] = true;

            for(int j=1; j<=N; j++){
                if(!check[j] && graph[min_index][j]!=-1){
                    if(distance[j]>distance[min_index]+graph[min_index][j]){
                        distance[j] = distance[min_index]+graph[min_index][j];
                    }
                }
            }
        }
        return distance;
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글