[백준]#1967 트리의 지름

SeungBird·2021년 5월 11일
0

⌨알고리즘(백준)

목록 보기
331/401

문제

트리(tree)는 사이클이 없는 무방향 그래프이다. 트리에서는 어떤 두 노드를 선택해도 둘 사이에 경로가 항상 하나만 존재하게 된다. 트리에서 어떤 두 노드를 선택해서 양쪽으로 쫙 당길 때, 가장 길게 늘어나는 경우가 있을 것이다. 이럴 때 트리의 모든 노드들은 이 두 노드를 지름의 끝 점으로 하는 원 안에 들어가게 된다.

이런 두 노드 사이의 경로의 길이를 트리의 지름이라고 한다. 정확히 정의하자면 트리에 존재하는 모든 경로들 중에서 가장 긴 것의 길이를 말한다.

입력으로 루트가 있는 트리를 가중치가 있는 간선들로 줄 때, 트리의 지름을 구해서 출력하는 프로그램을 작성하시오. 아래와 같은 트리가 주어진다면 트리의 지름은 45가 된다.

트리의 노드는 1부터 n까지 번호가 매겨져 있다.

입력

파일의 첫 번째 줄은 노드의 개수 n(1 ≤ n ≤ 10,000)이다. 둘째 줄부터 n-1개의 줄에 각 간선에 대한 정보가 들어온다. 간선에 대한 정보는 세 개의 정수로 이루어져 있다. 첫 번째 정수는 간선이 연결하는 두 노드 중 부모 노드의 번호를 나타내고, 두 번째 정수는 자식 노드를, 세 번째 정수는 간선의 가중치를 나타낸다. 간선에 대한 정보는 부모 노드의 번호가 작은 것이 먼저 입력되고, 부모 노드의 번호가 같으면 자식 노드의 번호가 작은 것이 먼저 입력된다. 루트 노드의 번호는 항상 1이라고 가정하며, 간선의 가중치는 100보다 크지 않은 양의 정수이다.

출력

첫째 줄에 트리의 지름을 출력한다.

예제 입력 1

12
1 2 3
1 3 2
2 4 5
3 5 11
3 6 9
4 7 1
4 8 7
5 9 15
5 10 4
6 11 6
6 12 10

예제 출력 1

45

풀이

이 문제는 bfs(너비 우선 탐색) 알고리즘을 이용해서 트리를 구성한 뒤에 LCA 알고리즘을 이용해서 답을 구할 수 있었다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int N;
    static int[] depth;
    static int[] parent;
    static int[] cost;
    static ArrayList<Integer>[] tree;

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        N = Integer.parseInt(br.readLine());

        parent = new int[N+1];
        depth = new int[N+1];
        cost = new int[N+1];
        tree = new ArrayList[N+1];
        for(int i=1; i<=N; i++)
            tree[i] = new ArrayList<>();

        boolean[] isLeaf = new boolean[N+1];
        for(int i=0; i<N-1; i++) {
            String[] input = br.readLine().split(" ");
            int parent = Integer.parseInt(input[0]);
            int child = Integer.parseInt(input[1]);
            int c = Integer.parseInt(input[2]);

            tree[parent].add(child);
            cost[child] = c;
            isLeaf[parent] = true;
        }

        make_tree();

        ArrayList<Integer> leaf = new ArrayList<>();    //리프 노드 끼리의 거리를 구하기 위한 리프노드 리스트
        leaf.add(1);                                    //루트의 자식이 하나뿐이면 루트에서 리프까지 거리가 최대이기 때문에 루트도 넣어줌
        for(int i=1; i<=N; i++) {
            if(!isLeaf[i])
                leaf.add(i);
        }

        int max = 0;
        for(int i=0; i<leaf.size()-1; i++) {        //리프-리프 지름, 리프-루트 지름중 가장 큰값 구하기
            for(int j=i+1; j<leaf.size(); j++)
                max = Math.max(max, lca(leaf.get(i), leaf.get(j)));
        }

        System.out.println(max);
    }

    static int lca(int a, int b) {    //lca 알고리즘
        int sum = 0;

        while(true){
            if(a==b)
                return sum;

            if(depth[a] == depth[b]) {
                while(a!=b) {
                    sum += cost[a];
                    sum += cost[b];
                    a = parent[a];
                    b = parent[b];
                }
            }

            else {
                if(depth[a]>depth[b]) {
                    while(depth[a]>depth[b]) {
                        sum += cost[a];
                        a = parent[a];
                    }
                }
                else {
                    while(depth[a]<depth[b]) {
                        sum += cost[b];
                        b = parent[b];
                    }
                }
            }
        }
    }

    public static void make_tree() {
        Queue<Integer> queue = new LinkedList<>();    //루트인 1 부터 트리구성
        queue.add(1);

        while(!queue.isEmpty()) {
            int temp = queue.poll();

            for(int child : tree[temp]) {
                if(parent[child]!=0) continue;

                parent[child] = temp;
                depth[child] = depth[temp]+1;
                queue.add(child);
            }
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글