[백준]#4991 로봇 청소기

SeungBird·2020년 8월 30일
0

⌨알고리즘(백준)

목록 보기
149/401

문제

오늘은 직사각형 모양의 방을 로봇 청소기를 이용해 청소하려고 한다. 이 로봇 청소기는 유저가 직접 경로를 설정할 수 있다.

방은 크기가 1×1인 정사각형 칸으로 나누어져 있으며, 로봇 청소기의 크기도 1×1이다. 칸은 깨끗한 칸과 더러운 칸으로 나누어져 있으며, 로봇 청소기는 더러운 칸을 방문해서 깨끗한 칸으로 바꿀 수 있다.

일부 칸에는 가구가 놓여져 있고, 가구의 크기도 1×1이다. 로봇 청소기는 가구가 놓여진 칸으로 이동할 수 없다.

로봇은 한 번 움직일 때, 인접한 칸으로 이동할 수 있다. 또, 로봇은 같은 칸을 여러 번 방문할 수 있다.

방의 정보가 주어졌을 때, 더러운 칸을 모두 깨끗한 칸으로 만드는데 필요한 이동 횟수의 최솟값을 구하는 프로그램을 작성하시오.

입력

입력은 여러 개의 테스트케이스로 이루어져 있다.

각 테스트 케이스의 첫째 줄에는 방의 가로 크기 w와 세로 크기 h가 주어진다. (1 ≤ w, h ≤ 20) 둘째 줄부터 h개의 줄에는 방의 정보가 주어진다. 방의 정보는 4가지 문자로만 이루어져 있으며, 각 문자의 의미는 다음과 같다.

  • .: 깨끗한 칸
  • *: 더러운 칸
  • x: 가구
  • o: 로봇 청소기의 시작 위치

더러운 칸의 개수는 10개를 넘지 않으며, 로봇 청소기의 개수는 항상 하나이다.

입력의 마지막 줄에는 0이 두 개 주어진다.

출력

각각의 테스트 케이스마다 더러운 칸을 모두 깨끗한 칸으로 바꾸는 이동 횟수의 최솟값을 한 줄에 하나씩 출력한다. 만약, 방문할 수 없는 더러운 칸이 존재하는 경우에는 -1을 출력한다.

예제 입력 1

7 5
.......
.o...*.
.......
.*...*.
.......
15 13
.......x.......
...o...x....*..
.......x.......
.......x.......
.......x.......
...............
xxxxx.....xxxxx
...............
.......x.......
.......x.......
.......x.......
..*....x....*..
.......x.......
10 10
..........
..o.......
..........
..........
..........
.....xxxxx
.....x....
.....x.*..
.....x....
.....x....
0 0

예제 출력 1

8
49
-1

풀이

이 문제는 DFS알고리즘을 이용한 순열(Permutation)과 BFS알고리즘을 이용해서 풀 수 있었다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int h;
    static int w;
    static char[][] map;
    static int[] dx = {-1, 1, 0, 0};
    static int[] dy = {0, 0, -1, 1};
    static Pair[] dirty;
    static int size;
    static int res;
    static Pair start;
    static int[][] graph;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

        loop:while(true) {
            String[] str = br.readLine().split(" ");
            h = Integer.parseInt(str[1]);
            w = Integer.parseInt(str[0]);
            dirty= new Pair[11];
            res = Integer.MAX_VALUE;
            size = 1;

            if(h==0 && w==0)
                return ;

            map = new char[h][w];
            start = new Pair(0, 0, 0);

            for(int i=0; i<h; i++) {
                String input = br.readLine();

                for(int j=0; j<w; j++) {
                    map[i][j] = input.charAt(j);

                    if(map[i][j]=='o')
                        start = new Pair(i, j, 0);

                    if(map[i][j]=='*') {
                        dirty[size] = new Pair(i, j, 0);
                        size++;
                    }
                }
            }
            dirty[0] = start;
            graph = new int[size][size];

            for(int i=0; i<size-1; i++) {
                for(int j=i+1; j<size; j++){
                    int len = bfs(dirty[i], dirty[j]);
                    if(len==-1) {
                        System.out.println(-1);
                        continue loop;
                    }

                    graph[i][j] = len;
                    graph[j][i] = len;
                }
            }

            boolean[] selected = new boolean[size];
            int[] list = new int[size];
            selected[0] = true;
            list[0] = 0;
            permu(selected, list,  1);
            System.out.println(res);
        }
    }

    static void permu(boolean[] selected, int[] list,  int idx) {
        if(idx==size) {
            int sum = 0;

            for(int i=0; i<size-1; i++) {
                sum += graph[list[i]][list[i+1]];
            }

            res = Math.min(res, sum);
            return;
        }

        for(int i=0; i<size; i++) {
            if(!selected[i]) {
                selected[i] = true;
                list[idx] = i;
                permu(selected, list, idx+1);
                selected[i] = false;
            }
        }
    }

    static int bfs(Pair start, Pair end) {
        Queue<Pair> queue = new LinkedList<>();
        boolean[][] visited = new boolean[h][w];
        visited[start.x][start.y] = true;
        queue.add(new Pair(start.x, start.y, 0));

        while(!queue.isEmpty()) {
            Pair p = queue.poll();

            for(int i=0; i<4; i++) {
                int X = p.x+dx[i];
                int Y = p.y+dy[i];

                if(X<0 || Y<0 || X>=h || Y>=w || map[X][Y]=='x' || visited[X][Y]) continue;

                if(X==end.x && Y==end.y) {
                    return p.d+1;
                }

                visited[X][Y] = true;
                queue.add(new Pair(X, Y, p.d+1));
            }
        }

        return -1;
    }

    static class Pair {
        int x;
        int y;
        int d;

        public Pair(int x, int y, int d) {
            this.x=x;
            this.y=y;
            this.d=d;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글