백준 [JAVA] :: 1260번 DFS와 BFS

smi·2023년 2월 7일
0

BAEKJOON (백준)

목록 보기
34/56

📚 문제 정의

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.


📝 입력

첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.

  • 예제 입력 1
4 5 1
1 2
1 3
1 4
2 4
3 4
  • 예제 입력 2
5 5 3
5 4
5 2
1 2
3 4
3 1
  • 예제 입력 3
1000 1 1000
999 1000

📝 출력

첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.

  • 예제 출력 1
1 2 4 3
1 2 3 4
  • 예제 출력 2
3 1 2 5 4
3 1 4 2 5
  • 예제 출력 3
1000 999
1000 999

💡 코드

import java.util.*;

public class Main {
    static int N;
    static int M;
    static int V;
    static int check[][];
    static boolean checked[];

    public static void main(String[] args) {
        Scanner s = new Scanner(System.in);
        N = s.nextInt();
        M = s.nextInt();
        V = s.nextInt();
        check = new int[N+1][N+1];
        checked = new boolean[N+1];

        for(int i = 0; i < M; i++) {
            int a = s.nextInt();
            int b = s.nextInt();
            check[a][b] = check[b][a] = 1;
        }

        dfs(V);
        checked = new boolean[N+1];
        System.out.println();

        bfs();
    }

    public static void dfs(int i) {
        checked[i] = true;
        System.out.print(i + " ");

        for(int j = 1; j <= N; j++) {
            if(check[i][j] == 1 && checked[j] == false) {
                dfs(j);
            }
        }
    }

    public static void bfs() {
        Queue<Integer> queue = new LinkedList<Integer>();
        queue.offer(V);
        checked[V] = true;
        System.out.print(V + " ");

        while(!queue.isEmpty()) {
            int temp = queue.poll();

            for(int j = 1; j <= N; j++) {
                if(check[temp][j] == 1 && checked[j] == false) {
                    queue.offer(j);
                    checked[j] = true;
                    System.out.print(j + " ");
                }
            }
        }
    }
}
profile
공부한 거 올려요 :)

0개의 댓글