전자정부프레임워크 maven-resources-plugin 에러

thyoondev·2021년 5월 4일
4
post-thumbnail
Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6 Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6


Errors occurred during the build. Errors running builder 'Maven Project Builder' on project 'egov'. Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6 Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6 Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6 Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6


Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.6: Could not transfer artifact org.apache.maven.plugins:maven-resources-plugin:pom:2.6 from/to central (https://repo.maven.apache.org/maven2): Received fatal alert: protocol_version -> [Help 1] [ERROR]

전자정부프레임워크를 사용하여 만들어진 사이트 유지보수를 하던 중, 로컬 환경 세팅에서 maven-resources-plugin 이라는 에러가났다.

dependencies를 못 잡는것 같아서 단순하게 maven repository 문제라고 생각했다.
그래서 단순하게 .m2 폴더를 삭제하고 maven update를 했지만 같은 에러가 출력됐다.

먼저 조금 찾아보니 메이븐 저장소에서 지원하는 jdk버전과 전자정부프레임워크 dependencies 주소가 변경됐다고한다.

아래가 시도해서 해결한 방법이다.

  1. 이클립스의 자바 버전을 1.8 이상으로 변경

    (java 1.7 프로젝트였다.)

  2. 프로젝트java build path 설정

    마찬가지로 프로젝트의 java build path에 들어가서 프로젝트 jdk도
    1.8 이상으로 변경

  3. pom.xml 수정

<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-compiler-plugin</artifactId>
  <configuration>
    <source>1.7</source> //1.8로 수정
    <target>1.7</target> //1.8로 수정
    <encoding>UTF-8</encoding>
  </configuration>
</plugin>
 
  1. 메이븐 저장소 url변경

    메이븐 센트럴 레포지토리 정책이 변경되어 2020년 1월 15일부터 HTTPS를 사용해야 한다.
    전자정부프레임워크 레포지토리도 다음 URL로 변경하시는게 안정적이다.
http://repo1.maven.org/maven2/
=> https://repo1.maven.org/maven2/

http://repo.maven.apache.org/maven2/
=> https://repo.maven.apache.org/maven2/

http://www.egovframe.go.kr/maven/
=> http://maven.egovframe.kr:8080/maven/
  1. repository 삭제

    C:\Users\로그인계정.m2\repository 폴더를 삭제

  2. 이클립스 재시작

  3. maven update

    해결됐으면 자바 버전을 다시 1.7로 낮춰도 문제없이 실행된다.

profile
Practice and repeat

0개의 댓글