맥북 M1 STS3 설치 오류 해결

wijoonwu·2022년 7월 14일
1

Error Report

목록 보기
9/9
post-thumbnail

오류 및 문제상황

https://github.com/spring-attic/toolsuite-distribution/wiki/Spring-Tool-Suite-3

국비지원 과정 중 STS3 설치가 필요하여 상기 링크에서 맥용 STS3을 다운로드 받고,
STS3을 실행시키려고 하자 아래 오류 메시지가 나왔다.

The JVM shared library ... does not contain the JNI_CreateJavaVm

원인과 해결 방법

내 경우에는 ARM 64bit JDK 를 사용한 것이 원인이었다.
azul 사이트에서 intel 용 JDK (x86 64bit)를 다운로드 받은 후
JAVA_HOME 경로와 STS.ini 파일을 해당 JDK로 수정한 뒤 STS3이 정상 실행 되었다.

상세 해결 방법

(1) intel JDK 설치

azul 사이트에서 intel 용 JDK (x86 64bit)를 다운로드 받는다.

(2) JAVA_HOME 환경 변수 수정

 vim ~/.bash_profile

터미널을 열고 위 명령어를 입력해서~/.bash_profile(맥 설정에 따라 ~/.zshrc 혹은 ~/. bashrc)의 JAVA_HOME 경로를 수정한다.

export JAVA_HOME=/Library/Java/JavaVirtualMachines/{java 버전}/Contents/Home
export PATH=$JAVA_HOME/bin:$PATH

위와 같은 화면이 나오면 i 를 눌러 insert 모드로 전환한 뒤 다운로드 받았던 JDK 경로를 적어준다.
그리고 esc 키를 누르고 :wq 를 눌러 해당 파일을 저장하고 나온다.

source ~/.bash.profile

그리고 터미널에서 위 명령어를 입력해 변경 내용이 반영되도록 한다.

(3) STS.ini 파일 수정

Finder 에서 STS3 가 설치된 경로를 열고, STS.app 우클릭 후 패키지 내용 보기를 선택한다.

Contents/Eclipse 폴더 안에 있는 STS.ini 파일을 터미널에서 vim 으로 열거나 VS Code 등의 편집기를 사용해서 파일을 수정한다.

-vm
/Library/Java/JavaVirtualMachines/{java 버전}/Contents/Home/bin/java

파일의 맨 상단에 위와 같이 적어주고, 아래와 같이 Dosgi.requiredJavaVersion 부분도 java 버전에 맞는 숫자로 입력한 뒤 저장한다.

-Dosgi.requiredJavaVersion=11

이후 STS.app 을 실행하면 정상적으로 작동한다.

2개의 댓글

comment-user-thumbnail
2022년 9월 18일

덕분에 잘 해결했어요~~

1개의 답글