P_10866 덱

castlehi·2022년 4월 15일
0

CodingTest

목록 보기
66/67
post-thumbnail

10866 덱

시간 제한메모리 제한제출정답맞힌 사람정답 비율
0.5 초 (추가 시간 없음) 256 MB42648232451967956.374%

문제

정수를 저장하는 덱(Deque)를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여덟 가지이다.

  • push_front X: 정수 X를 덱의 앞에 넣는다.
  • push_back X: 정수 X를 덱의 뒤에 넣는다.
  • pop_front: 덱의 가장 앞에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • pop_back: 덱의 가장 뒤에 있는 수를 빼고, 그 수를 출력한다. 만약, 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size: 덱에 들어있는 정수의 개수를 출력한다.
  • empty: 덱이 비어있으면 1을, 아니면 0을 출력한다.
  • front: 덱의 가장 앞에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • back: 덱의 가장 뒤에 있는 정수를 출력한다. 만약 덱에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1

15
push_back 1
push_front 2
front
back
size
empty
pop_front
pop_back
pop_front
size
empty
pop_back
push_front 3
empty
front

예제 출력 1

2
1
2
0
2
1
-1
0
1
-1
0
3

예제 입력 2

22
front
back
pop_front
pop_back
push_front 1
front
pop_back
push_back 2
back
pop_front
push_front 10
push_front 333
front
back
pop_back
pop_back
push_back 20
push_back 1234
front
back
pop_back
pop_back

예제 출력 2

-1
-1
-1
-1
1
1
2
2
333
10
10
333
20
1234
1234
20

코드

import java.io.*;
import java.util.ArrayDeque;
import java.util.Arrays;
import java.util.Deque;

public class P_10866 {
    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));

        int n = Integer.parseInt(br.readLine());
        Deque<Integer> deque = new ArrayDeque<>();

        for (int i = 0; i < n; i++) {
            Object[] command = Arrays.stream(br.readLine().split(" ")).toArray();

            if (command[0].equals("push_front")) deque.addFirst(Integer.parseInt((String) command[1]));
            else if (command[0].equals("push_back")) deque.add(Integer.parseInt((String) command[1]));
            else if (command[0].equals("pop_front")) {
                if (deque.isEmpty()) bw.write(-1 + "\n");
                else bw.write(deque.removeFirst() + "\n");
            }
            else if (command[0].equals("pop_back")) {
                if (deque.isEmpty()) bw.write(-1 + "\n");
                else bw.write(deque.removeLast() + "\n");
            }
            else if (command[0].equals("size")) bw.write(deque.size() + "\n");
            else if (command[0].equals("empty")) {
                if (deque.isEmpty()) bw.write(1 + "\n");
                else bw.write(0 + "\n");
            }
            else if (command[0].equals("front")) {
                if (deque.isEmpty()) bw.write(-1 + "\n");
                else bw.write(deque.getFirst() + "\n");
            }
            else {
                if (deque.isEmpty()) bw.write(-1 + "\n");
                else bw.write(deque.getLast() + "\n");
            }
        }

        bw.flush();
    }
}

코드 설명

자바 자료구조인 Deque를 ArrayDeque로 구현했다.

profile
Back-end Developer

0개의 댓글