[BOJ] (1697) 숨바꼭질 (Java)

zerokick·2023년 4월 23일
0

Coding Test

목록 보기
81/120
post-thumbnail

(1697) 숨바꼭질 (Java)


시간 제한메모리 제한제출정답맞힌 사람정답 비율
2 초128 MB198743572943603625.284%

문제

수빈이는 동생과 숨바꼭질을 하고 있다. 수빈이는 현재 점 N(0 ≤ N ≤ 100,000)에 있고, 동생은 점 K(0 ≤ K ≤ 100,000)에 있다. 수빈이는 걷거나 순간이동을 할 수 있다. 만약, 수빈이의 위치가 X일 때 걷는다면 1초 후에 X-1 또는 X+1로 이동하게 된다. 순간이동을 하는 경우에는 1초 후에 2*X의 위치로 이동하게 된다.

수빈이와 동생의 위치가 주어졌을 때, 수빈이가 동생을 찾을 수 있는 가장 빠른 시간이 몇 초 후인지 구하는 프로그램을 작성하시오.

입력

첫 번째 줄에 수빈이가 있는 위치 N과 동생이 있는 위치 K가 주어진다. N과 K는 정수이다.

출력

수빈이가 동생을 찾는 가장 빠른 시간을 출력한다.

예제 입력 1

5 17

예제 출력 1

4

힌트

수빈이가 5-10-9-18-17 순으로 가면 4초만에 동생을 찾을 수 있다.

출처

Olympiad > USA Computing Olympiad > 2006-2007 Season > USACO US Open 2007 Contest > Silver 2번

데이터를 추가한 사람: arat5724, cohan, djm03178
문제를 번역한 사람: author6

비슷한 문제

12851번. 숨바꼭질 2
13549번. 숨바꼭질 3
13913번. 숨바꼭질 4

알고리즘 분류

그래프 이론
그래프 탐색
너비 우선 탐색

Solution

import java.io.*;
import java.util.Arrays;
import java.util.LinkedList;
import java.util.Queue;
import java.util.StringTokenizer;

public class BOJ1697 {
    public static int n, k;
    public static int[] subin;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
        StringTokenizer st = new StringTokenizer(br.readLine());

        n = Integer.parseInt(st.nextToken());
        k = Integer.parseInt(st.nextToken());
        br.close();

        subin = new int[100001];
        Arrays.fill(subin, -1);

        Queue<Integer> q = new LinkedList<Integer>();
        subin[n] = 0;
        q.offer(n);

        while(!q.isEmpty()) {
            int bfN = q.poll();

            if(bfN == k) {
                System.out.println(subin[bfN]);
            }

            for(int i = 0; i < 3; i++) {
                if(i == 0) {
                    if((bfN+1) <= 100000 && subin[bfN + 1] == -1) {
                        q.offer(bfN + 1);
                        subin[bfN + 1] = subin[bfN] + 1;
                    }
                } else if(i == 1) {
                    if((bfN-1) >= 0 && subin[bfN - 1] == -1) {
                        q.offer(bfN - 1);
                        subin[bfN - 1] = subin[bfN] + 1;
                    }
                } else {
                    if((bfN*2) <= 100000 && subin[bfN * 2] == -1) {
                        q.offer(bfN * 2);
                        subin[bfN * 2] = subin[bfN] + 1;
                    }
                }
            }
        }
    }
}

Solution

최단 시간 구하기 문제의 경우 BFS를 먼저 떠올려보자.

profile
Opportunities are never lost. The other fellow takes those you miss.

0개의 댓글