[BOJ] (2667) 단지번호붙이기 (Java)

zerokick·2023년 4월 26일
0

Coding Test

목록 보기
88/120
post-thumbnail

(2667) 단지번호붙이기 (Java)


시간 제한메모리 제한제출정답맞힌 사람정답 비율
1 초128 MB150577659994177741.670%

문제

<그림 1>과 같이 정사각형 모양의 지도가 있다. 1은 집이 있는 곳을, 0은 집이 없는 곳을 나타낸다. 철수는 이 지도를 가지고 연결된 집의 모임인 단지를 정의하고, 단지에 번호를 붙이려 한다. 여기서 연결되었다는 것은 어떤 집이 좌우, 혹은 아래위로 다른 집이 있는 경우를 말한다. 대각선상에 집이 있는 경우는 연결된 것이 아니다. <그림 2>는 <그림 1>을 단지별로 번호를 붙인 것이다. 지도를 입력하여 단지수를 출력하고, 각 단지에 속하는 집의 수를 오름차순으로 정렬하여 출력하는 프로그램을 작성하시오.

입력

첫 번째 줄에는 지도의 크기 N(정사각형이므로 가로와 세로의 크기는 같으며 5≤N≤25)이 입력되고, 그 다음 N줄에는 각각 N개의 자료(0혹은 1)가 입력된다.

출력

첫 번째 줄에는 총 단지수를 출력하시오. 그리고 각 단지내 집의 수를 오름차순으로 정렬하여 한 줄에 하나씩 출력하시오.

예제 입력 1

7
0110100
0110101
1110101
0000111
0100000
0111110
0111000

예제 출력 1

3
7
8
9

출처

Olympiad > 한국정보올림피아드 > KOI 1996 > 초등부 1번

잘못된 데이터를 찾은 사람: djm03178
데이터를 추가한 사람: djm03178, jh05013
문제의 오타를 찾은 사람: metadata

알고리즘 분류

그래프 이론
그래프 탐색
너비 우선 탐색
깊이 우선 탐색

Solution

import java.io.*;
import java.util.*;

public class BOJ2667 {
    public static int n;
    public static int[][] house;
    public static boolean[][] visit;
    public static class Pair {

        int x, y;
        Pair(int x, int y) {
            this.x = x;
            this.y = y;
        }
    }
    public static Queue<Pair> q;

    public static int[] dx = {1, 0, -1, 0};
    public static int[] dy = {0, -1, 0, 1};

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));

        n = Integer.parseInt(br.readLine());        // 지도 크기 n x n

        // 지도 그리기
        house = new int[n][n];
        visit = new boolean[n][n];

        for(int i = 0; i < n; i++) {
            String[] strArr = br.readLine().split("");
            for(int j = 0; j < n; j++) {
                house[i][j] = Integer.parseInt(strArr[j]);
            }
        }
        br.close();

        // 집 찾기
        List<Integer> list = findHouse();

        // 단지 수
        bw.write(String.valueOf(list.remove(list.size()-1)) + "\n");

        // 단지 내 집의 수 오름차순 정렬
        list.sort(Comparator.naturalOrder());
        for(int i = 0; i < list.size(); i++) {
            bw.write(String.valueOf(list.get(i)) + "\n");
        }

        bw.flush();
        bw.close();
    }

    public static List<Integer> findHouse() {
        List<Integer> returnList = new ArrayList<Integer>();
        
        int area = 0;   // 단지수

        q = new LinkedList<Pair>();

        for(int i = 0; i < n; i++) {
            for(int j = 0; j < n; j++) {

                // 방문하지 않은 집이면 큐에 등록하고 방문처리
                if(house[i][j] == 1 && !visit[i][j]) {
                    q.offer(new Pair(i, j));
                    visit[i][j] = true;
                    area++;     // 단지수 + 1
                }

                int cnt = 0;    // 단지 내 집의 수

                // 인접 칸 탐색
                while(!q.isEmpty()) {
                    cnt++;      // 단지 내 집의 수 + 1
                    Pair pollCell = q.poll();

                    for(int k = 0; k < 4; k++) {
                        int nx = pollCell.x + dx[k];
                        int ny = pollCell.y + dy[k];

                        // 인접 칸이 지도 범위를 벗어나거나, 집이 없거나, 이미 방문한 집이면 skip
                        if(isNotRange(nx, ny) || house[nx][ny] == 0 || visit[nx][ny]) continue;

                        // 큐에 등록하고 방문처리
                        q.offer(new Pair(nx, ny));
                        visit[nx][ny] = true;
                    }
                }

                if(cnt > 0) returnList.add(cnt);
            }
        }

        returnList.add(area);

        return returnList;
    }

    public static boolean isNotRange(int x, int y) {
        return (x < 0 || x >= n || y < 0 || y >= n) ? true : false;
    }
}

Feedback

profile
Opportunities are never lost. The other fellow takes those you miss.

0개의 댓글