[BOJ] (7562) 나이트의 이동 (Java)

zerokick·2023년 4월 24일
0

Coding Test

목록 보기
83/120
post-thumbnail

(7562) 나이트의 이동 (Java)


시간 제한메모리 제한제출정답맞힌 사람정답 비율
1 초256 MB48828250981866450.273%

문제

체스판 위에 한 나이트가 놓여져 있다. 나이트가 한 번에 이동할 수 있는 칸은 아래 그림에 나와있다. 나이트가 이동하려고 하는 칸이 주어진다. 나이트는 몇 번 움직이면 이 칸으로 이동할 수 있을까?

입력

입력의 첫째 줄에는 테스트 케이스의 개수가 주어진다.

각 테스트 케이스는 세 줄로 이루어져 있다. 첫째 줄에는 체스판의 한 변의 길이 l(4 ≤ l ≤ 300)이 주어진다. 체스판의 크기는 l × l이다. 체스판의 각 칸은 두 수의 쌍 {0, ..., l-1} × {0, ..., l-1}로 나타낼 수 있다. 둘째 줄과 셋째 줄에는 나이트가 현재 있는 칸, 나이트가 이동하려고 하는 칸이 주어진다.

출력

각 테스트 케이스마다 나이트가 최소 몇 번만에 이동할 수 있는지 출력한다.

예제 입력 1

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

예제 출력 1

5
28
0

출처

University > Tu-Darmstadt Programming Contest > TUD Contest 2001 3번

문제를 번역한 사람: baekjoon
데이터를 추가한 사람: sait2000
문제의 오타를 찾은 사람: sgchoi5

알고리즘 분류

그래프 이론
그래프 탐색
너비 우선 탐색

Solution

import java.io.*;
import java.util.Arrays;
import java.util.LinkedList;
import java.util.Queue;
import java.util.StringTokenizer;

public class Main {
    public static int tc, i;
    public static char[][] board;
    public static int[][] visit;
    public static int[] dx = {1, 2, 2, 1, -1, -2, -2, -1};
    public static int[] dy = {-2, -1, 1, 2, 2, 1, -1, -2};
    public static Queue<Pair> q;

    public static class Pair {
        int x, y;

        Pair(int x, int y) {
            this.x = x;
            this.y = y;
        }
    }

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
        StringTokenizer st;

        tc = Integer.parseInt(br.readLine());

        for(int t = 0; t < tc; t++) {
            i = Integer.parseInt(br.readLine());

            q = new LinkedList<Pair>();
            board = new char[i][i];
            visit = new int[i][i];
            for(int k = 0; k < i; k++) {
                Arrays.fill(visit[k], -1);
            }

            for(int k = 0; k < 2; k++) {
                st = new StringTokenizer(br.readLine());
                int x = Integer.parseInt(st.nextToken());
                int y = Integer.parseInt(st.nextToken());
                if(k == 0) {
                    board[x][y] = 'N';

                    q.offer(new Pair(x, y));
                    visit[x][y] = 0;
                } else {
                    board[x][y] = 'G';
                }
            }

            bw.write(String.valueOf(findGoal()) + "\n");
        }
        bw.flush();
        bw.close();
    }

    public static int findGoal() {
        while(!q.isEmpty()) {
            Pair pollCell = q.poll();

            if(board[pollCell.x][pollCell.y] == 'G') return visit[pollCell.x][pollCell.y];

            for(int k = 0; k < 8; k++) {
                int nx = pollCell.x + dx[k];
                int ny = pollCell.y + dy[k];

                if(isNotRange(nx, ny) || visit[nx][ny] != -1) continue;

                q.offer(new Pair(nx, ny));
                visit[nx][ny] = visit[pollCell.x][pollCell.y] + 1;
            }
        }

        return 0;
    }

    public static boolean isNotRange(int x, int y) {
        return (x < 0 || x >= i || y < 0 || y >= i) ? true : false;
    }
}

Feedback

테스트 케이스가 여러개 주어지는 경우 입력을 어떻게 받을 것인지 잘 생각해야 한다.

profile
Opportunities are never lost. The other fellow takes those you miss.

0개의 댓글