# node sass

10개의 포스트

node-sass 설치 및 설정

* node-sass : https://www.npmjs.com/package/node-sass 1. 초기화 결과 ~ package.json 파일 생성 2. 설치 결과 ~ node-modules 디렉토리 생성, package-lock.json 파일 생성 3. 설정 1) package.json 파일에서 "scripts" 객체에 "node-sass": "node-sass" 항목 추가 2) "sass": "node-sass src/style.scss dest/style.css" 항목 추가 *guide 문서에서 Command Line Interface 섹션 참고 3) styles 디렉토리 안에 main.scss 파일 생성 4) "sass": "node-sass styles/main.scss style.css" 경로 수정 4. 실행 5. npm script 업데이트 _*guide 문서에서 Command Line In

2023년 2월 6일
·
0개의 댓글
·
post-thumbnail

Node.js 업데이트 후 node-sass 오류

Issue 오랜만에 프로젝트 잘 있나 한 번 실행해보려고 노트북에 node를 설치했다. 분명 안전한 릴리스가 14버전이었던 것 같은데 벌써 16버전이 됐다. 멍청한 나는 그걸 몰랐고 용감하게 npm install때렸다. sass, scss를 사용해야하는 것도 있지만.. 오류나서 프로젝트를 실행할 수 없다. (일단 nodeJs를 14버전으로 낮추는 방법이 있겠지만 안 됐다. 이유는 기억 상실이라 못 적겠다.) Researching... 💀 뭐 거창하게 적었지만.. 계속 구글링... 버전 호환 nodeJs, node-sass 일단, NodeJs 버전과 호환이 되는 node-sass 버전을 이용해야 한다. | NodeJS | Supported node-sass version | Node Module | |---|---|---| | Node 17 | 7.0+ | 102 | | Node 16 | 6.0+ | 93 | | Node 15 | 5.0+, <7.0 |

2022년 4월 7일
·
1개의 댓글
·

mac os node 버전 변경(node-sass)

node 명령어 버전 node -v 사용가능한 노드 검색 brew search node 노드 연결 해제 brew unlink node 노드 설치 brew install node@16 노드 연결 brew link node@16 node-sass 에 따른 node 버전 참고 node버전과 node-sass 버전이 다르면 컴파일시 에러 발생가능성 높음.

2022년 1월 30일
·
0개의 댓글
·
post-thumbnail

node sass 설치 및 적용

sass 프로그래밍 요소를 추가해 css 작성과 유지보수를 효율적으로 관리해준다. scss 파일을 작성하면 css 파일로 변경해준다. npmjs - sass 사용방법 node, npm 설치 후, 아래 코드를 터미널에 입력하여 설치 확인 작업할 폴더에 npm init sass 패키지를 import 체크 부분 추가 코드 추가 5-1. index.html 5-2. package.json> "scripts" -

2022년 1월 16일
·
0개의 댓글
·
post-thumbnail

Vue - npm install 할 때 node-sass 에러 발생한다면?

node-sass 에러 발생시 npm rebuild node-sass 로 리빌드 해주면 된다. npm install 직후 서버를 실행하면 node-sass 관련 2에러가 뜨는데 버전이 안맞는다는 내용일 경우, 위 커맨드로 node-sass를 삭제하고 다시 설치한다. 또는 node-sass@4.9.0버전이 설치되지 않거나 위 방법으로도 해결이 되지않는다면 윈도우용 빌드 툴을 설치하거나, 위 두 패키지를 설치하면 해결된다. 본인은 위와 같은 문제로 해결이 되지 않아서 node 14.17.0 또는 node 14.17.0 #2 **노드 16버전에서 14버전으로 재

2021년 12월 20일
·
0개의 댓글
·
post-thumbnail

Node-sass 설치 에러 & npm install 설치 에러

Node-sass 설치 에러 npm install 직후 서버를 실행하면 node-sass 관련 에러가 뜨는데 버전이 안맞는다는 내용일 경우, 위 커맨드로 node-sass를 삭제하고 다시 설치한다. 또는 node-sass@4.9.0버전이 설치되지 않거나 위 방법으로도 해결이 되지않는다면 윈도우용 빌드 툴을 설치하거나, 위 두 패키지를 설치하면 해결된다. 본인은 위와 같은 문제로 해결이 되지 않아서 node 14.17.0 또는 node 14.17.0 #2 노드 16버전에서 14버전으로 재설치 해서해결 되었다..

2021년 12월 11일
·
0개의 댓글
·

TIL 210810

오늘 한 일 node-sass 설치 자바스크립트와 잠시 멀어지고 싶어서 도피 하는 겸 미뤄뒀던 scss를 배워보고자 강의를 틀었다. 분명 도피라고 했지만 내가 개발 환경 세팅을 얼마나 삽질할지 설치하기 전의 나는 몰랐다... 삽질 과정 npm i node-sass 이라 쓰고 삽질의 시작이라고 읽는다. node-sass 홈페이지에 있는 코드를 보고 그냥 다짜고짜 터미널에 붙여넣었다. 육안으로는 설치도 잘 된 것 같고 그랬는데 구글에서 node.js와 버전이 맞지 않으면 컴파일 오류가 생긴다는 글을 다섯개 정도 보고 나서 확인해보니... 내가 설치한 node.js는 14.17.1 버전이었고 방금 설치한 node-sass는 6.0 버전이었다. 예.. 어쩌겠어요 다시 설치해야죠... **

2021년 8월 10일
·
0개의 댓글
·
post-thumbnail

React Sass 설치 에러 해결

3줄 요약 -Sass는 유용한 CSS 확장(extension)입니다. -Sass는 2006년 Ruby로 처음 개발되어서 최근까지 Dart Sass로 재구현되었는데, Libsass나 node-sass는 현재 유지 관리는 되고 있으나 폐지되었으므로 Dart Sass를 사용하도록 합니다. (이하 npm install -g sass) -그러나 Sass버전 5.0.0과 충돌이 일어나므로 4버전으로 깔아야합니다. 출처: https://poiemaweb.com/sass-basics https://sass-lang.com/install

2021년 5월 25일
·
0개의 댓글
·
post-thumbnail

sass설치중 오류

분명 sass는 잘 설치가 되어있는데.... 버전도 4.14.4로 5.00.0이 아닌 하위 버전으로 잘 설치했구만... 리액트에선 계속 compile할수 없다고 오류를 띄운다 ....하아..이거때문에 몇시간을 버렷는지.... 애플코딩을 듣다가 생긴 오류인데 아직 확인방법을 못찾아 게시판에 도움을 요청한 상태이다. https://stackoverflow.com/QUESTIONS/64625050/ERROR-NODE-SASS-VERSION-5-0-0-IS-INCOMPATIBLE-WITH-4-0-0 위 url에서 확인한대로 수정했는데도 안되고있고 node-gyp도 설치하고 node init 으로 package.json확인해봐도 문제는 없는데.... npm install해서 보면 계속 -4048 오류를 내보내는 중이다. 차라리 어떻게 구현할까 고민하면서 시간 쓰는게 나은것 같다. 이렇게 시간 버리면....정말 답도없다.... 가서 구글링을 좀 더 해봐야겠다. 나중에 방법 찾

2020년 12월 3일
·
2개의 댓글
·

SASS/SCSS 설치부터 간단 사용법 정리

SASS & SCSS란? CSS전처리기(CSS pre-processor)라 불리는 SASS(Syntactically Awesome StyleSheet)는 CSS의 단점을 보완한 CSS의 확장형이다. SCSS와 SASS 비슷한 두개가 있는데(이외도 있지만 여기서는 SCSS만 다룬다), SASS를 더 편리하게 수정한 버전이 SCSS이다. 확장자는 .scss 사용하며, 브라우저에서 SASS구문을 이해하지 못하기 때문에 컴파일하는 작업이 필요하다. 컴파일 작업을 위해서는 SASS 환경설치가 필요하다. node-sass 설치하기 를 커멘드라인에 입력하여 node-sass를 설치하자. 다른 사람들은 한번에 잘 설치하던대 나는 에러파티에 초대 되었당..(Mac os) ![node-sass error party](https://images.velog.io/images/hwang-eunji/post/fe1089c1-1afd-4fc9-ab62-f5acbf04a96d/%E1%84

2020년 2월 20일
·
1개의 댓글
·