G4 백준-14502번: 연구소

BrokenFinger98·2024년 8월 7일
0

Problem Solving

목록 보기
4/29

문제

인체에 치명적인 바이러스를 연구하던 연구소에서 바이러스가 유출되었다. 다행히 바이러스는 아직 퍼지지 않았고, 바이러스의 확산을 막기 위해서 연구소에 벽을 세우려고 한다.

연구소는 크기가 N×M인 직사각형으로 나타낼 수 있으며, 직사각형은 1×1 크기의 정사각형으로 나누어져 있다. 연구소는 빈 칸, 벽으로 이루어져 있으며, 벽은 칸 하나를 가득 차지한다.

일부 칸은 바이러스가 존재하며, 이 바이러스는 상하좌우로 인접한 빈 칸으로 모두 퍼져나갈 수 있다. 새로 세울 수 있는 벽의 개수는 3개이며, 꼭 3개를 세워야 한다.

예를 들어, 아래와 같이 연구소가 생긴 경우를 살펴보자.

2 0 0 0 1 1 0
0 0 1 0 1 2 0
0 1 1 0 1 0 0
0 1 0 0 0 0 0
0 0 0 0 0 1 1
0 1 0 0 0 0 0
0 1 0 0 0 0 0

이때, 0은 빈 칸, 1은 벽, 2는 바이러스가 있는 곳이다. 아무런 벽을 세우지 않는다면, 바이러스는 모든 빈 칸으로 퍼져나갈 수 있다.

2행 1열, 1행 2열, 4행 6열에 벽을 세운다면 지도의 모양은 아래와 같아지게 된다.

2 1 0 0 1 1 0
1 0 1 0 1 2 0
0 1 1 0 1 0 0
0 1 0 0 0 1 0
0 0 0 0 0 1 1
0 1 0 0 0 0 0
0 1 0 0 0 0 0

바이러스가 퍼진 뒤의 모습은 아래와 같아진다.

2 1 0 0 1 1 2
1 0 1 0 1 2 2
0 1 1 0 1 2 2
0 1 0 0 0 1 2
0 0 0 0 0 1 1
0 1 0 0 0 0 0
0 1 0 0 0 0 0

벽을 3개 세운 뒤, 바이러스가 퍼질 수 없는 곳을 안전 영역이라고 한다. 위의 지도에서 안전 영역의 크기는 27이다.

연구소의 지도가 주어졌을 때 얻을 수 있는 안전 영역 크기의 최댓값을 구하는 프로그램을 작성하시오.

입력

첫째 줄에 지도의 세로 크기 N과 가로 크기 M이 주어진다. (3 ≤ N, M ≤ 8)

둘째 줄부터 N개의 줄에 지도의 모양이 주어진다. 0은 빈 칸, 1은 벽, 2는 바이러스가 있는 위치이다. 2의 개수는 2보다 크거나 같고, 10보다 작거나 같은 자연수이다.

빈 칸의 개수는 3개 이상이다.

출력

첫째 줄에 얻을 수 있는 안전 영역의 최대 크기를 출력한다.

예제 입력 1

7 7
2 0 0 0 1 1 0
0 0 1 0 1 2 0
0 1 1 0 1 0 0
0 1 0 0 0 0 0
0 0 0 0 0 1 1
0 1 0 0 0 0 0
0 1 0 0 0 0 0

예제 출력 1

27

예제 입력 2

4 6
0 0 0 0 0 0
1 0 0 0 0 2
1 1 1 0 0 2
0 0 0 0 0 2

예제 출력 2

9

예제 입력 3

8 8
2 0 0 0 0 0 0 2
2 0 0 0 0 0 0 2
2 0 0 0 0 0 0 2
2 0 0 0 0 0 0 2
2 0 0 0 0 0 0 2
0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0

예제 출력 3

3

이론

완전탐색(브루트포스) : 모든 경우의 수를 탐색하는 알고리즘, 어떤 맵에서 어떤 것을 색칠하거나 뭘 세운다라고 했을 때 경우의 수들끼리 서로의 상태값이 영향을 미치지 않게 하려는 방법이 바로 원복입니다. 보통은 방문 배열인 visited를 통해 "색칠하고" "다시지운다(원복)"를 통해 해하는 것

백트래킹 : 완전탐색 & 가지치기이며 최대한 불필요한 탐색을 피하는 것

접근법 1

import java.util.*;
import java.io.*;
import java.lang.*;

class Pair {
    int y;
    int x;

    public Pair(int y, int x) {
        this.y = y;
        this.x = x;
    }
}

public class Main {
    static int N, M;
    static int result;
    static int[][] mp;
    static int[][] mp1;
    static List<Pair> virus = new ArrayList<>();
    static List<Pair> beWall = new ArrayList<>();
    static int[] dy = {1, 0, -1, 0};
    static int[] dx = {0, 1, 0, -1};

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        StringTokenizer st = new StringTokenizer(br.readLine());
        N = Integer.parseInt(st.nextToken());
        M = Integer.parseInt(st.nextToken());
        mp = new int[N][M];

        for (int i = 0; i < N; ++i) {
            st = new StringTokenizer(br.readLine());
            for (int j = 0; j < M; ++j) {
                mp[i][j] = Integer.parseInt(st.nextToken());
                if (mp[i][j] == 2) {
                    virus.add(new Pair(i, j));
                } else if (mp[i][j] == 0) {
                    beWall.add(new Pair(i, j));
                }
            }
        }

        for (int i = 0; i < beWall.size(); ++i) {
            for (int j = i + 1; j < beWall.size(); ++j) {
                for (int k = j + 1; k < beWall.size(); ++k) {
                    back();
                    mp1[beWall.get(i).y][beWall.get(i).x] = 1;
                    mp1[beWall.get(j).y][beWall.get(j).x] = 1;
                    mp1[beWall.get(k).y][beWall.get(k).x] = 1;
                    bfs();
                }
            }
        }
        System.out.println(result);
    }

    static void back() {
        mp1 = new int[N][M];
        for (int i = 0; i < N; ++i) {
            for (int j = 0; j < M; ++j) {
                mp1[i][j] = mp[i][j];
            }
        }
    }

    static void bfs() {
        Deque<Pair> queue = new ArrayDeque<>();
        for (Pair pair : virus) {
            queue.offer(pair);
        }
        while (!queue.isEmpty()) {
            Pair now = queue.poll();
            for (int i = 0; i < 4; ++i) {
                int ny = now.y + dy[i];
                int nx = now.x + dx[i];
                if (ny < 0 || ny >= N || nx < 0 || nx >= M) continue;
                if (mp1[ny][nx] == 0) {
                    mp1[ny][nx] = 2;
                    queue.push(new Pair(ny, nx));
                }
            }
        }
        int sum = 0;
        for (int i = 0; i < N; ++i) {
            for (int j = 0; j < M; ++j) {
                if (mp1[i][j] == 0) ++sum;
            }
        }
        result = Math.max(sum, result);
    }
}

기존의 mp에 새로운 벽을 추가한 mp1 배열을 매번 초기화 하며 진행했다.

Solution

import java.util.*;
import java.io.*;
import java.lang.*;

class Pair {
    int y;
    int x;

    public Pair(int y, int x) {
        this.y = y;
        this.x = x;
    }
}

public class Main {
    static int N, M;
    static int result;
    static int[][] mp;
    static int[][] visited;
    static List<Pair> virus = new ArrayList<>();
    static List<Pair> beWall = new ArrayList<>();
    static int[] dy = {1, 0, -1, 0};
    static int[] dx = {0, 1, 0, -1};

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        StringTokenizer st = new StringTokenizer(br.readLine());
        N = Integer.parseInt(st.nextToken());
        M = Integer.parseInt(st.nextToken());
        mp = new int[N][M];

        for (int i = 0; i < N; ++i) {
            st = new StringTokenizer(br.readLine());
            for (int j = 0; j < M; ++j) {
                mp[i][j] = Integer.parseInt(st.nextToken());
                if (mp[i][j] == 2) {
                    virus.add(new Pair(i, j));
                } else if (mp[i][j] == 0) {
                    beWall.add(new Pair(i, j));
                }
            }
        }

        for (int i = 0; i < beWall.size(); ++i) {
            for (int j = i + 1; j < beWall.size(); ++j) {
                for (int k = j + 1; k < beWall.size(); ++k) {
                    mp[beWall.get(i).y][beWall.get(i).x] = 1;
                    mp[beWall.get(j).y][beWall.get(j).x] = 1;
                    mp[beWall.get(k).y][beWall.get(k).x] = 1;
                    bfs();
                    mp[beWall.get(i).y][beWall.get(i).x] = 0;
                    mp[beWall.get(j).y][beWall.get(j).x] = 0;
                    mp[beWall.get(k).y][beWall.get(k).x] = 0;
                }
            }
        }
        System.out.println(result);
    }

    static void bfs() {
        Queue<Pair> queue = new ArrayDeque<>();
        visited = new int[N][M];
        for (Pair pair : virus) {
            visited[pair.y][pair.x] = 1;
            queue.offer(pair);
        }
        while (!queue.isEmpty()) {
            Pair now = queue.poll();
            for (int i = 0; i < 4; ++i) {
                int ny = now.y + dy[i];
                int nx = now.x + dx[i];
                if (ny < 0 || ny >= N || nx < 0 || nx >= M) continue;
                if (mp[ny][nx] == 0 && visited[ny][nx] == 0) {
                    visited[ny][nx] = visited[now.y][now.x] + 1;
                    queue.offer(new Pair(ny, nx));
                }
            }
        }
        int sum = 0;
        for (int i = 0; i < N; ++i) {
            for (int j = 0; j < M; ++j) {
                if (mp[i][j] == 0 && visited[i][j] == 0) ++sum;
            }
        }
        result = Math.max(sum, result);
    }
}

bfs를 호출하기 전에 벽을 세우고 다음 벽을 세우기 전에 원래의 mp상태로 원복을 진행했다.
(첫번째 방법은 mp1 배열의 초기화 과정이 필요하고, 두번째 방법은 visited 배열의 초기화 과정이 필요하여 시간 차이는 거의 없는거 같다. 그러나 원복의 개념이 들어간 두번째 풀이가 더 좋은 풀이라고 생각된다.)

https://www.acmicpc.net/problem/14502

profile
나는야 개발자

0개의 댓글