[백준] 9184번 - PYTHON

NoowaH·2021년 10월 25일
0
post-thumbnail
post-custom-banner

'백준 9184 - 신나는 함수실행'

문제

재귀 호출만 생각하면 신이 난다! 아닌가요?

다음과 같은 재귀함수 w(a, b, c)가 있다.

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
    1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
    w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
    w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
    w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

위의 함수를 구현하는 것은 매우 쉽다. 하지만, 그대로 구현하면 값을 구하는데 매우 오랜 시간이 걸린다. (예를 들면, a=15, b=15, c=15)

a, b, c가 주어졌을 때, w(a, b, c)를 출력하는 프로그램을 작성하시오.

입력

입력은 세 정수 a, b, c로 이루어져 있으며, 한 줄에 하나씩 주어진다. 입력의 마지막은 -1 -1 -1로 나타내며, 세 정수가 모두 -1인 경우는 입력의 마지막을 제외하면 없다.

출력

입력으로 주어진 각각의 a, b, c에 대해서, w(a, b, c)를 출력한다.

제한

  • -50 ≤ a, b, c ≤ 50

예제 입력 1 복사

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

예제 출력 1 복사

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


✔ My Solution - Memoization


import sys
input = sys.stdin.readline

def w(a, b, c):
    if a <= 0 or b <= 0 or c <= 0:
        return 1
    if a > 20 or b > 20 or c > 20:
        return (w(20, 20, 20))
    if dp[a][b][c]:
        return dp[a][b][c]
    if a < b and b < c:
        dp[a][b][c] = w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
        return dp[a][b][c]
    else:
        dp[a][b][c] = (w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1))
        return dp[a][b][c]

dp = [[[0]*(21) for _ in range(21)] for _ in range(21)]

while True:
    a, b, c = map(int, input().split())
    if a == -1 and b == -1 and c == -1:
        break
        
    print(f"w({a}, {b}, {c}) = {w(a,b,c)}")

step 1

dp = [[[0]*(21) for _ in range(21)] for _ in range(21)]

w(a, b, c) 함수 내부에 복잡한 재귀함수가 실행되는 경우는 a, b, c의 값 범위 = 1 ~ 20

  • 1 - 20 일때 의 결과값 memoization dp array 생성
  • 20 개의 [0]*21 값을 가진 3차원 배열 (index 0 은 dummy 배열)

step 2

def w(a, b, c):
    if a <= 0 or b <= 0 or c <= 0:
        return 1
    if a > 20 or b > 20 or c > 20:
        return (w(20, 20, 20))
    if dp[a][b][c]:
        return dp[a][b][c]
    if a < b and b < c:
        dp[a][b][c] = w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
        return dp[a][b][c]
    else:
        dp[a][b][c] = (w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1))
        return dp[a][b][c]

a <= 0 or b <= 0 or c <= 0 & if a > 20 or b > 20 or c > 20

  • 두 조건식은 재귀함수를 발생시키지 않기 때문에 똑같이 포함

if dp[a][b][c]:

  • memoization dp에 0이 아닌 연산이 된 데이터가 있을 때 반복연산을 안하고 바로 데이터 반환
  • a < b and b < celse 구문이 아직 연산이 된 데이터가 없을 시 dp[a][b][c]에 저장 후 반환

step 3

while True:
    a, b, c = map(int, input().split())
    if a == -1 and b == -1 and c == -1:
        break
        
    print(f"w({a}, {b}, {c}) = {w(a,b,c)}")

-1 -1 -1 : 반복문 종료

✅ fstring 사용해서 문제에 알맞는 형식의 문자열데이터 출력

profile
조하운
post-custom-banner

0개의 댓글