[백준] 9498. 시험성적 (feat. Javascript / node.js) 알고리즘

준리·2022년 4월 21일
0

자료구조알고리즘

목록 보기
13/38
post-thumbnail

조건문 단계

: [9498]

시험 점수를 입력받아 90 ~ 100점은 A, 80 ~ 89점은 B, 70 ~ 79점은 C, 60 ~ 69점은 D, 나머지 점수는 F를 출력하는 프로그램을 작성하시오.

예제 입력

첫째 줄에 시험 점수가 주어진다. 시험 점수는 0보다 크거나 같고, 100보다 작거나 같은 정수이다.

100

예제 출력

시험 성적을 출력한다.

A

제출

const input = require("fs").readFileSync("/dev/stdin").toString().split(" ");

var a = parseInt(input);

if (a >= 90) {
    console.log("A");
} else if (a >= 80) {
    console.log("B");
} else if (a >= 70) {
    console.log("C");
} else if (a >= 60) {
    console.log("D");
} else {
    console.log("F");
}


무엇을 해결해야 하는가?

조건문을 잘 활용하면 된다.

숏코딩

a = require("fs").readFileSync("dev/stdin");
console.log(a > 89 ? "A" : a > 79 ? "B" : a > 69 ? "C" : a > 59 ? "D" : "F");

굳이 정수화 시켜주지 않아도된다.
중첩 삼항연산자를 통해 그냥 출력하면 된다.

다음에 써봐야겠다.
if문 안녕

profile
트렌디 풀스택 개발자

0개의 댓글