[Python] 백준 4358 생태학 (Counter)

선주·2022년 1월 19일
0

Python PS

목록 보기
26/65
post-thumbnail

📌 문제

생태학에서 나무의 분포도를 측정하는 것은 중요하다. 그러므로 당신은 미국 전역의 나무들이 주어졌을 때, 각 종이 전체에서 몇 %를 차지하는지 구하는 프로그램을 만들어야 한다.

입력

프로그램은 여러 줄로 이루어져 있으며, 한 줄에 하나의 나무 종 이름이 주어진다. 어떤 종 이름도 30글자를 넘지 않으며, 입력에는 최대 10,000개의 종이 주어지고 최대 1,000,000그루의 나무가 주어진다.

출력

주어진 각 종의 이름을 사전순으로 출력하고, 그 종이 차지하는 비율을 백분율로 소수점 4째자리까지 반올림해 함께 출력한다.

예제 입력 1

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

예제 출력 1

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483


📌 풀이

💬 Code

import sys
from collections import Counter
input = sys.stdin.readline

trees = []
cnt = 0

while True:
    name = input().rstrip()
    if not name:
        break
    trees.append(name)
    cnt += 1

trees = sorted(Counter(trees).items())

for i in range(len(trees)):
    print(trees[i][0], "{:.4f}".format(trees[i][1]/cnt*100))

💡 Solution

입력의 개수를 모를 때 while-try-except문을 썼었는데 왜인지 이 문제에서는 그게 안 먹히길래 구글링의 힘을 빌려 while-if not 세트로 사용! 더이상 input이 들어오지 않을 때 break를 걸어준다.

input으로 들어오는 나무 이름들을 trees 리스트에 넣어주고, Counter(trees)로 각 이름의 빈도를 세어준다. 다만 출력할 때 빈도순이 아닌 이름 사전순으로 출력해야 하므로 정렬단계를 거쳐야 한다.

print(Counter(['hello', 'hello', 'goodbye', 'thanks']))
print(sorted(Counter(['hello', 'hello', 'goodbye', 'thanks'])))

# Counter({'hello': 2, 'goodbye': 1, 'thanks': 1})
# ['goodbye', 'hello', 'thanks']

이렇게 Counter를 바로 sorted 구조로 만들어 버리면 key만 정렬되기 때문에

print(Counter(['hello', 'hello', 'goodbye', 'thanks']).items())
print(sorted(Counter(['hello', 'hello', 'goodbye', 'thanks']).items()))

# dict_items([('hello', 2), ('goodbye', 1), ('thanks', 1)])
# [('goodbye', 1), ('hello', 2), ('thanks', 1)]

Counter.items()로 key, value쌍을 함께 가져와서 sorted 구조로 만들어주어야 key, value쌍을 함께 정렬할 수 있다.


Counter

from collections import Counter
print(Counter('hello world'))
# Counter({'l': 3, 'o': 2, 'h': 1, 'e': 1, ' ': 1, 'w': 1, 'r': 1, 'd': 1})
  • Counter를 이용하면 이와 같이 각 요소의 개수를 세는 동작을 쉽게 수행할 수 있다.
  • Counter 클래스는 파이썬의 기본 자료구조인 사전(dictionary)를 확장하고 있기 때문에, 사전에서 제공하는 API를 그대로 사용할 수 있다.

소수점 표현법

a = "example1 : {:.2f}".format(1.23456789)
print(a)
# example1 : 1.23

b = "example2 : {:.2f} / {:.3f}".format(1.23456789, 3.456789)
print(b)
# example2 : 1.23 / 3.457

c = "example3 : {0:.2f} / {1:.1f}".format(3.22521321, 10.123456)
print(c)
# example3 : 3.23 / 10.1

d = "example4 : {1:.2f} / {0:.1f}".format(3.22521321, 10.123456)
print(d)
# example4 : 10.12 / 3.2
profile
기록하는 개발자 👀

0개의 댓글