[백준]#11404 플로이드

SeungBird·2020년 8월 28일
0

⌨알고리즘(백준)

목록 보기
112/401

문제

n(1 ≤ n ≤ 100)개의 도시가 있다. 그리고 한 도시에서 출발하여 다른 도시에 도착하는 m(1 ≤ m ≤ 100,000)개의 버스가 있다. 각 버스는 한 번 사용할 때 필요한 비용이 있다.

모든 도시의 쌍 (A, B)에 대해서 도시 A에서 B로 가는데 필요한 비용의 최솟값을 구하는 프로그램을 작성하시오.

입력

첫째 줄에 도시의 개수 n(1 ≤ n ≤ 100)이 주어지고 둘째 줄에는 버스의 개수 m(1 ≤ m ≤ 100,000)이 주어진다. 그리고 셋째 줄부터 m+2줄까지 다음과 같은 버스의 정보가 주어진다. 먼저 처음에는 그 버스의 출발 도시의 번호가 주어진다. 버스의 정보는 버스의 시작 도시 a, 도착 도시 b, 한 번 타는데 필요한 비용 c로 이루어져 있다. 시작 도시와 도착 도시가 같은 경우는 없다. 비용은 100,000보다 작거나 같은 자연수이다.

시작 도시와 도착 도시를 연결하는 노선은 하나가 아닐 수 있다.

출력

n개의 줄을 출력해야 한다. i번째 줄에 출력하는 j번째 숫자는 도시 i에서 j로 가는데 필요한 최소 비용이다. 만약, i에서 j로 갈 수 없는 경우에는 그 자리에 0을 출력한다.

예제 입력 1

5
14
1 2 2
1 3 3
1 4 1
1 5 10
2 4 2
3 4 1
3 5 1
4 5 3
3 5 10
3 1 8
1 4 2
5 1 7
3 4 2
5 2 4

예제 출력 1

0 2 3 1 4
12 0 15 2 5
8 5 0 1 1
10 7 13 0 3
7 4 10 6 0

풀이

이 문제는 플로이드-와샬 또는 다익스트라 같은 최단거리 알고리즘을 이용해서 풀 수 있다. 이 풀이는 다익스트라 알고리즘을 이용한 풀이다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    static int[][] graph;
    static int N;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        N = Integer.parseInt(br.readLine());
        graph = new int[N+1][N+1];
        int K = Integer.parseInt(br.readLine());

        for(int i=0; i<K; i++) {
            String[] input = br.readLine().split(" ");
            int start = Integer.parseInt(input[0]);
            int end = Integer.parseInt(input[1]);
            int cost = Integer.parseInt(input[2]);

            if(graph[start][end]!=0)
                graph[start][end] = Math.min(graph[start][end], cost);
            else
                graph[start][end] = cost;
        }

        for(int i=1; i<=N; i++) {
            int[] arr = dijkstra(i);

            for(int j=1; j<=N; j++) {
                if(arr[j]==Integer.MAX_VALUE)
                    System.out.print("0 ");
                else
                    System.out.print(arr[j] + " ");
            }
            System.out.println();
        }
    }

    static int[] dijkstra(int v){
        int distance[] = new int[N+1];
        boolean[] check = new boolean[N+1];

        for(int i=1; i<=N; i++){
            distance[i] = Integer.MAX_VALUE;
        }

        distance[v] = 0;
        check[v] = true;

        for(int i=1; i<=N; i++){
            if(!check[i] && graph[v][i]!=0){
                distance[i] = graph[v][i];
            }
        }

        for(int i=0; i<N-1; i++){
            int min = Integer.MAX_VALUE;
            int min_index = 0;

            for(int j=1; j<=N; j++){
                if(!check[j] && distance[j]!=Integer.MAX_VALUE){
                    if(distance[j]<min ){
                        min=distance[j];
                        min_index = j;
                    }
                }
            }

            check[min_index] = true;

            for(int j=1; j<=N; j++){
                if(!check[j] && graph[min_index][j]!=0){
                    if(distance[j]>distance[min_index]+graph[min_index][j]){
                        distance[j] = distance[min_index]+graph[min_index][j];
                    }
                }
            }
        }
        return distance;
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글