[백준]#11779 최소비용 구하기 2

SeungBird·2020년 12월 1일
0

⌨알고리즘(백준)

목록 보기
241/401

문제

n(1≤n≤1,000)개의 도시가 있다. 그리고 한 도시에서 출발하여 다른 도시에 도착하는 m(1≤m≤100,000)개의 버스가 있다. 우리는 A번째 도시에서 B번째 도시까지 가는데 드는 버스 비용을 최소화 시키려고 한다. 그러면 A번째 도시에서 B번째 도시 까지 가는데 드는 최소비용과 경로를 출력하여라. 항상 시작점에서 도착점으로의 경로가 존재한다.

입력

첫째 줄에 도시의 개수 n(1≤n≤1,000)이 주어지고 둘째 줄에는 버스의 개수 m(1≤m≤100,000)이 주어진다. 그리고 셋째 줄부터 m+2줄까지 다음과 같은 버스의 정보가 주어진다. 먼저 처음에는 그 버스의 출발 도시의 번호가 주어진다. 그리고 그 다음에는 도착지의 도시 번호가 주어지고 또 그 버스 비용이 주어진다. 버스 비용은 0보다 크거나 같고, 100,000보다 작은 정수이다.

그리고 m+3째 줄에는 우리가 구하고자 하는 구간 출발점의 도시번호와 도착점의 도시번호가 주어진다.

출력

첫째 줄에 출발 도시에서 도착 도시까지 가는데 드는 최소 비용을 출력한다.

둘째 줄에는 그러한 최소 비용을 갖는 경로에 포함되어있는 도시의 개수를 출력한다. 출발 도시와 도착 도시도 포함한다.

셋째 줄에는 최소 비용을 갖는 경로를 방문하는 도시 순서대로 출력한다.

예제 입력 1

5
8
1 2 2
1 3 3
1 4 1
1 5 10
2 4 2
3 4 1
3 5 1
4 5 3
1 5

예제 출력 1

4
3
1 3 5

풀이

이 문제는 Dijkstra(다익스트라) 알고리즘을 이용해서 풀 수 있었다. 다익스트라 알고리즘은 Queue를 이용해서 구현했고 경로는 백트래킹을 이용해서 풀었다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int N;
    static ArrayList<Pair>[] graph;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        N = Integer.parseInt(br.readLine());
        int M = Integer.parseInt(br.readLine());
        graph = new ArrayList[N+1];

        for(int i=1; i<=N; i++)
            graph[i] = new ArrayList<>();

        for(int i=0; i<M; i++) {
            String[] input = br.readLine().split(" ");
            int start = Integer.parseInt(input[0]);
            int end = Integer.parseInt(input[1]);
            int cost = Integer.parseInt(input[2]);

            graph[start].add(new Pair(end, cost));
        }

        String[] input = br.readLine().split(" ");
        int start = Integer.parseInt(input[0]);
        int end = Integer.parseInt(input[1]);

        dijkstra(start, end);
    }

    public static void dijkstra(int start, int end) {
        Queue<Pair> queue = new LinkedList<>();
        int[] distance = new int[N+1];
        for(int i=0; i<=N; i++)
            distance[i] = Integer.MAX_VALUE;

        distance[start] = 0;
        int[] path = new int[N+1];
        queue.add(new Pair(start, 0));

        while(!queue.isEmpty()) {
            Pair temp = queue.poll();
            
            if(distance[temp.end] < temp.cost) continue;

            for(int i=0; i<graph[temp.end].size(); i++) {
                Pair p = graph[temp.end].get(i);

                if(distance[p.end]>p.cost+temp.cost) {
                    queue.add(new Pair(p.end, temp.cost+p.cost));
                    distance[p.end] = temp.cost+p.cost;
                    path[p.end] = temp.end;
                }
            }
        }

        StringBuilder sb = new StringBuilder();
        int cnt = 1;
        int idx = end;
        sb.append(end);
        while(path[idx]!=0) {
            sb.insert(0, path[idx]+" ");
            idx = path[idx];
            cnt++;
        }
        sb.insert(0, cnt+"\n");
        sb.insert(0, distance[end]+"\n");
        System.out.println(sb.toString());
    }

    public static class Pair {
        int end;
        int cost;

        public Pair(int end, int cost) {
            this.end = end;
            this.cost = cost;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글