[백준]#14442 벽 부수고 이동하기 2

SeungBird·2020년 8월 27일
0

⌨알고리즘(백준)

목록 보기
80/401

문제

N×M의 행렬로 표현되는 맵이 있다. 맵에서 0은 이동할 수 있는 곳을 나타내고, 1은 이동할 수 없는 벽이 있는 곳을 나타낸다. 당신은 (1, 1)에서 (N, M)의 위치까지 이동하려 하는데, 이때 최단 경로로 이동하려 한다. 최단경로는 맵에서 가장 적은 개수의 칸을 지나는 경로를 말하는데, 이때 시작하는 칸과 끝나는 칸도 포함해서 센다.

만약에 이동하는 도중에 벽을 부수고 이동하는 것이 좀 더 경로가 짧아진다면, 벽을 K개 까지 부수고 이동하여도 된다.

맵이 주어졌을 때, 최단 경로를 구해 내는 프로그램을 작성하시오.

입력

첫째 줄에 N(1 ≤ N ≤ 1,000), M(1 ≤ M ≤ 1,000), K(1 ≤ K ≤ 10)이 주어진다. 다음 N개의 줄에 M개의 숫자로 맵이 주어진다. (1, 1)과 (N, M)은 항상 0이라고 가정하자.

출력

첫째 줄에 최단 거리를 출력한다. 불가능할 때는 -1을 출력한다.

예제 입력 1

6 4 1
0100
1110
1000
0000
0111
0000

예제 출력 1

15

예제 입력 2

6 4 2
0100
1110
1000
0000
0111
0000

예제 출력 2

9

예제 입력 3

4 4 3
0111
1111
1111
1110

예제 출력 3

-1

풀이

이 문제는 벽 부수고 이동하기 문제에서 조금 심화된 문제로 벽 부수고 이동하기 문제에서는 3차원 배열의 면을 2개만 선언했지만 여기에서는 면을 K개 선언해서 풀었다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int[][] map;
    static int N;
    static int M;
    static int K;
    static int result = -1;
    static int[] dx = {-1, 1, 0, 0};
    static int[] dy = {0, 0, -1, 1};

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] str = br.readLine().split(" ");
        N = Integer.parseInt(str[0]);
        M = Integer.parseInt(str[1]);
        K = Integer.parseInt(str[2]);
        map = new int[N+1][M+1];

        for(int i=1; i<=N; i++) {
            String input = br.readLine();
            for(int j=1; j<=M; j++) {
                map[i][j] = input.charAt(j-1) - '0';
            }
        }
        BFS(1, 1);
        System.out.println(result);
    }


    public static void BFS(int x, int y) {
        Queue<Pair> queue = new LinkedList<>();
        boolean[][][] visited = new boolean[K+1][N+1][M+1];
        visited[0][x][y]=true;
        queue.add(new Pair(x, y, 1,0));

        while(!queue.isEmpty()) {
            Pair p = queue.poll();

            if(p.x==N && p.y==M) {
                result = p.cnt;
                break;
            }

            for(int i=0; i<4; i++) {
                int X = p.x+dx[i];
                int Y = p.y+dy[i];
                int cnt = p.cnt+1;
                int isBreak = p.isBreak;

                if(X>=1 && Y>=1 && X<=N && Y<=M) {
                    if(isBreak==K) {
                        if (map[X][Y]==0 && !visited[isBreak][X][Y]) {
                            visited[isBreak][X][Y] = true;
                            queue.add(new Pair(X, Y, cnt, isBreak));
                        }
                    }

                    else if(isBreak<K){
                        if(map[X][Y]==0 && !visited[isBreak][X][Y]) {
                            visited[isBreak][X][Y] = true;
                            queue.add(new Pair(X, Y, cnt, isBreak));
                        }

                        else if(map[X][Y]==1 && !visited[isBreak+1][X][Y]) {
                            visited[isBreak+1][X][Y] = true;
                            queue.add(new Pair(X, Y, cnt, isBreak+1));
                        }
                    }
                }
            }
        }
    }

    static class Pair {
        int x;
        int y;
        int cnt;
        int isBreak;

        public Pair(int x, int y, int cnt, int isBreak) {
            this.x=x;
            this.y=y;
            this.cnt=cnt;
            this.isBreak=isBreak;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글