[백준]#1446 지름길

SeungBird·2021년 5월 29일
0

⌨알고리즘(백준)

목록 보기
344/401

문제

매일 아침, 세준이는 학교에 가기 위해서 차를 타고 D킬로미터 길이의 고속도로를 지난다. 이 고속도로는 심각하게 커브가 많아서 정말 운전하기도 힘들다. 어느 날, 세준이는 이 고속도로에 지름길이 존재한다는 것을 알게 되었다. 모든 지름길은 일방통행이고, 고속도로를 역주행할 수는 없다.

세준이가 운전해야 하는 거리의 최솟값을 출력하시오.

입력

첫째 줄에 지름길의 개수 N과 고속도로의 길이 D가 주어진다. N은 12 이하이고, D는 10,000보다 작거나 같은 자연수이다. 둘째 줄부터 N개의 줄에 지름길의 시작 위치, 도착 위치, 지름길의 길이가 주어진다. 모든 위치와 길이는 10,000보다 작거나 같은 음이 아닌 정수이다. 지름길의 시작 위치는 도착 위치보다 작다.

출력

세준이가 운전해야하는 거리의 최솟값을 출력하시오.

예제 입력 1

5 150
0 50 10
0 50 20
50 100 10
100 151 10
110 140 90

예제 출력 1

70

풀이

이 문제는 정렬과 다이나믹 프로그래밍을 이용해서 풀 수 있었다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;

public class Main {

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        int N = Integer.parseInt(input[0]);
        int D = Integer.parseInt(input[1]);
        ArrayList<Pair> quick = new ArrayList<>();

        for(int i=0; i<N; i++) {
            input = br.readLine().split(" ");
            int start = Integer.parseInt(input[0]);
            int end = Integer.parseInt(input[1]);
            int cost = Integer.parseInt(input[2]);

            if(end>D || end-start<=cost) continue;
            quick.add(new Pair(start, end, cost));
        }

        Collections.sort(quick);      //정렬 메소드

        int[] dp = new int[D+1];
        int temp = 0;
        int idx = 0;

        while(temp<D) {
            while(idx<quick.size()) {
                Pair q = quick.get(idx);

                if(q.start!=temp) break;

                if(dp[q.end]==0)
                    dp[q.end] = dp[temp]+q.cost;
                else
                    dp[q.end] = Math.min(dp[temp]+q.cost, dp[q.end]);
                
                idx++;
            }

            if(dp[temp+1]==0)
                dp[temp+1] = dp[temp]+1;
            else
                dp[temp+1] = Math.min(dp[temp]+1, dp[temp+1]);

            temp++;
        }

        System.out.println(dp[D]);
    }

    public static class Pair implements Comparable<Pair>{   //지름길 출발 거리순으로 정렬
        int start;
        int end;
        int cost;

        public Pair(int start, int end, int cost) {
            this.start = start;
            this.end = end;
            this.cost = cost;
        }

        public int compareTo(Pair p) {
            return this.start > p.start ? 1 : -1;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글