[백준]#14923 미로 탈출

SeungBird·2021년 1월 2일
0

⌨알고리즘(백준)

목록 보기
254/401

문제

홍익이는 사악한 마법사의 꾐에 속아 N x M 미로 (Hx, Hy) 위치에 떨어졌다. 다행히도 홍익이는 마법사가 만든 미로의 탈출 위치(Ex, Ey)를 알고 있다. 하지만 미로에는 곳곳에 마법사가 설치한 벽이 있어 홍익이가 탈출하기 어렵게 하고 있다.

홍익이는 마법사의 연구실에서 훔친 지팡이가 있어, 벽을 길로 만들 수 있다. 그렇지만, 안타깝게도 마법의 지팡이는 단 한 번만 사용할 수 있다.

이때, 홍익이를 도와 미로에서 탈출할 수 있는지 알아보고, 할 수 있다면 가장 빠른 경로의 거리 D는 얼마인지 알아보자.

인접한 칸으로 이동하는데 똑같은 시간이 들고, 벽을 부수는 데 시간이 걸리지 않는다.

입력

N M
Hx Hy
Ex Ey
N X M 행렬
  • 2 ≤ N ≤ 1000, 2 ≤ M ≤ 1000
  • 1 ≤ Hx, Hy, Ex, Ey ≤ 1000
  • (Hx, Hy)≠ (Ex, Ey)
  • 행렬은 0과 1로만 이루어져 있고, 0이 빈 칸, 1이 벽이다.

출력

D (탈출 할 수 없다면, -1을 출력한다.)

예제 입력 1

5 6
1 1
5 6
0 1 1 1 0 0
0 1 1 0 0 0
0 1 0 0 1 0
0 1 0 0 1 0
0 0 0 1 1 0

예제 출력 1

11

풀이

이 문제는 bfs(너비 우선 탐색) 알고리즘을 이용해서 풀 수 있었다. 추가로 3차원 배열을 이용하면 쉽게 풀 수 있다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int N;
    static int M;
    static int[][] map;
    static int[] dx = {-1, 1, 0, 0};
    static int[] dy = {0, 0, -1, 1};

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        N = Integer.parseInt(input[0]);
        M = Integer.parseInt(input[1]);

        input = br.readLine().split(" ");
        Pair start = new Pair(Integer.parseInt(input[0]), Integer.parseInt(input[1]), 0, 0);
        input = br.readLine().split(" ");
        Pair end = new Pair(Integer.parseInt(input[0]), Integer.parseInt(input[1]), 0, 0);

        map = new int[N+1][M+1];

        for(int i=1; i<=N; i++) {
            input = br.readLine().split(" ");

            for(int j=1; j<=M; j++) {
                map[i][j] = Integer.parseInt(input[j-1]);
            }
        }

        bfs(start, end);
    }

    public static void bfs(Pair start, Pair end) {
        Queue<Pair> queue = new LinkedList<>();
        boolean[][][] visited = new boolean[N+1][M+1][2];
        visited[start.x][start.y][0] = true;
        queue.add(new Pair(start.x, start.y, 0, 0));

        while(!queue.isEmpty()) {
            Pair temp = queue.poll();

            if(temp.x==end.x && temp.y==end.y) {
                System.out.println(temp.t);
                return;
            }

            for(int i=0; i<4; i++) {
                int nx = temp.x + dx[i];
                int ny = temp.y + dy[i];

                if(nx<1 || nx>N || ny<1 || ny>M || visited[nx][ny][temp.f]) continue;

                if(map[nx][ny]==1 && temp.f==0) {
                    visited[nx][ny][temp.f] = true;
                    queue.add(new Pair(nx, ny, temp.t+1, 1));
                }

                else if(map[nx][ny]==0) {
                    visited[nx][ny][temp.f] = true;
                    queue.add(new Pair(nx, ny, temp.t+1, temp.f));
                }
            }
        }

        System.out.println(-1);
    }

    public static class Pair {
        int x;
        int y;
        int t;
        int f;

        public Pair(int x, int y, int t, int f) {
            this.x = x;
            this.y = y;
            this.t = t;
            this.f = f;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글