[백준]#3184 양

SeungBird·2020년 12월 29일
0

⌨알고리즘(백준)

목록 보기
253/401

문제

미키의 뒷마당에는 특정 수의 양이 있다. 그가 푹 잠든 사이에 배고픈 늑대는 마당에 들어와 양을 공격했다.

마당은 행과 열로 이루어진 직사각형 모양이다. 글자 '.' (점)은 빈 필드를 의미하며, 글자 '#'는 울타리를, 'o'는 양, 'v'는 늑대를 의미한다.

한 칸에서 수평, 수직만으로 이동하며 울타리를 지나지 않고 다른 칸으로 이동할 수 있다면, 두 칸은 같은 영역 안에 속해 있다고 한다. 마당에서 "탈출"할 수 있는 칸은 어떤 영역에도 속하지 않는다고 간주한다.

다행히 우리의 양은 늑대에게 싸움을 걸 수 있고 영역 안의 양의 수가 늑대의 수보다 많다면 이기고, 늑대를 우리에서 쫓아낸다. 그렇지 않다면 늑대가 그 지역 안의 모든 양을 먹는다.

맨 처음 모든 양과 늑대는 마당 안 영역에 존재한다.

아침이 도달했을 때 살아남은 양과 늑대의 수를 출력하는 프로그램을 작성하라.

입력

첫 줄에는 두 정수 R과 C가 주어지며(3 ≤ R, C ≤ 250), 각 수는 마당의 행과 열의 수를 의미한다.

다음 R개의 줄은 C개의 글자를 가진다. 이들은 마당의 구조(울타리, 양, 늑대의 위치)를 의미한다.

출력

하나의 줄에 아침까지 살아있는 양과 늑대의 수를 의미하는 두 정수를 출력한다.

예제 입력 1

6 6
...#..
.##v#.
#v.#.#
#.o#.#
.###.#
...###

예제 출력 1

0 2

예제 입력 2

8 8
.######.
#..o...#
#.####.#
#.#v.#.#
#.#.o#o#
#o.##..#
#.v..v.#
.######.

예제 출력 2

3 1

예제 입력 3

9 12
.###.#####..
#.oo#...#v#.
#..o#.#.#.#.
#..##o#...#.
#.#v#o###.#.
#..#v#....#.
#...v#v####.
.####.#vv.o#
.......####.

예제 출력 3

3 5

풀이

이 문제는 bfs(너비 우선 탐색) 알고리즘을 이용해서 풀 수 있었다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int N;
    static int M;
    static int wolf;
    static int sheep;
    static char[][] map;
    static boolean[][] visited;
    static int[] dx = {-1, 1, 0, 0};
    static int[] dy = {0, 0, -1, 1};

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        N = Integer.parseInt(input[0]);
        M = Integer.parseInt(input[1]);
        sheep = 0;
        wolf = 0;
        map = new char[N][M];
        visited = new boolean[N][M];
        Queue<Pair> queue = new LinkedList<>();

        for(int i=0; i<N; i++) {
            String str = br.readLine();
            for(int j=0; j<M; j++) {
                map[i][j] = str.charAt(j);

                if(map[i][j]=='v' || map[i][j]=='o')        //양이나 늑대가 있는 구역만 체크
                    queue.add(new Pair(i, j));
            }
        }

        while(!queue.isEmpty()) {               //양이나 늑대가 있는 구역 모두 확인
            Pair temp = queue.poll();

            if(!visited[temp.x][temp.y])
                bfs(temp.x, temp.y);            //구역 탐색
        }

        System.out.println(sheep+" "+wolf);
    }

    public static void bfs(int x, int y) {
        Queue<Pair> queue = new LinkedList<>();
        int w = 0;
        int s = 0;
        visited[x][y] = true;

        if(map[x][y]=='v') w++;
        if(map[x][y]=='o') s++;

        queue.add(new Pair(x, y));

        while(!queue.isEmpty()) {
            Pair temp = queue.poll();

            for(int i=0; i<4; i++) {
                int nx = temp.x + dx[i];
                int ny = temp.y + dy[i];

                if(nx<0 || nx>=N || ny<0 || ny>=M || map[nx][ny]=='#' || visited[nx][ny]) continue;

                if(map[nx][ny]=='o')
                    s++;

                if(map[nx][ny]=='v')
                    w++;

                visited[nx][ny] = true;
                queue.add(new Pair(nx, ny));
            }
        }

        if(s<=w)        //늑대가 이겼을 때
            wolf += w;

        else            //양이 이겼을 때
            sheep += s;
    }

    public static class Pair {
        int x;
        int y;

        public Pair(int x, int y) {
            this.x = x;
            this.y = y;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글