[백준]#16562 친구비

SeungBird·2020년 11월 23일
0

⌨알고리즘(백준)

목록 보기
236/401

문제

19학번 이준석은 학생이 N명인 학교에 입학을 했다. 준석이는 입학을 맞아 모든 학생과 친구가 되고 싶어한다. 하지만 준석이는 평생 컴퓨터랑만 대화를 하며 살아왔기 때문에 사람과 말을 하는 법을 모른다. 그런 준석이에게도 희망이 있다. 바로 친구비다!

학생 i에게 Ai만큼의 돈을 주면 그 학생은 1달간 친구가 되어준다! 준석이에게는 총 k원의 돈이 있고 그 돈을 이용해서 친구를 사귀기로 했다. 막상 친구를 사귀다 보면 돈이 부족해질 것 같다는 생각을 하게 되었다. 그래서 준석이는 “친구의 친구는 친구다”를 이용하기로 했다.

준석이는 이제 모든 친구에게 돈을 주지 않아도 된다!

위와 같은 논리를 사용했을 때, 가장 적은 비용으로 모든 사람과 친구가 되는 방법을 구하라.

입력

첫 줄에 학생 수 N (1 ≤ N ≤ 10,000)과 친구관계 수 M (0 ≤ M ≤ 10,000), 가지고 있는 돈 k (1 ≤ k ≤ 10,000,000)가 주어진다.

두번째 줄에 N개의 각각의 학생이 원하는 친구비 Ai가 주어진다. (1 ≤ Ai ≤ 10,000, 1 ≤ i ≤ N)

다음 M개의 줄에는 숫자 v, w가 주어진다. 이것은 학생 v와 학생 w가 서로 친구라는 뜻이다.

출력

준석이가 모든 학생을 친구로 만들 수 있다면, 친구로 만드는데 드는 최소비용을 출력한다. 만약 친구를 다 사귈 수 없다면, “Oh no”(따옴표 제거)를 출력한다.

예제 입력 1

5 3 20
10 10 20 20 30
1 3
2 4
5 4

예제 출력 1

20

예제 입력 2

5 3 10
10 10 20 20 30
1 3
2 4
5 4

예제 출력 2

Oh no

풀이

이 문제는 ArrayList 배열과 BFS(너비 우선 탐색) 알고리즘을 이용해서 풀 수 있었다. ArrayList 배열에 친구들의 관계를 저장하고 BFS 알고리즘을 이용해서 친구관계인 친구들의 모임들을 모두 찾아서 각 모임의 최소 친구비를 모두 더한 뒤 준석이가 가진 돈과 비교해서 답을 구했다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int[] costs;
    static ArrayList<Integer>[] graph;
    static boolean[] visited;

    public static void main(String[] args) throws Exception{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] input = br.readLine().split(" ");
        int N = Integer.parseInt(input[0]);
        int M = Integer.parseInt(input[1]);
        int k = Integer.parseInt(input[2]);
        int ans = 0;

        visited = new boolean[N+1];
        graph = new ArrayList[N+1];
        for(int i=1; i<=N; i++)
            graph[i] = new ArrayList<>();

        costs = new int[N+1];
        input = br.readLine().split(" ");
        for(int i=1; i<=N; i++)
            costs[i] = Integer.parseInt(input[i-1]);

        for(int i=0; i<M; i++) {
            input = br.readLine().split(" ");
            int a = Integer.parseInt(input[0]);
            int b = Integer.parseInt(input[1]);

            graph[a].add(b);
            graph[b].add(a);
        }

        for(int i=1; i<=N; i++) {
            if(!visited[i]) {
                ans += bfs(i);
            }
        }

        if(ans<=k)
            System.out.println(ans);

        else
            System.out.println("Oh no");
    }

    public static int bfs(int start) {
        Queue<Integer> queue = new LinkedList<>();
        int min = Integer.MAX_VALUE;
        visited[start] = true;
        queue.add(start);

        while(!queue.isEmpty()) {
            int temp = queue.poll();
            min = Math.min(min, costs[temp]);

            for(int i=0; i<graph[temp].size(); i++) {
                int end = graph[temp].get(i);

                if(!visited[end]) {
                    visited[end] = true;
                    queue.add(end);
                }
            }
        }

        return min;
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글