[백준]#17406 배열 돌리기 4

SeungBird·2020년 8월 28일
0

⌨알고리즘(백준)

목록 보기
110/401

문제

크기가 N×M 크기인 배열 A가 있을때, 배열 A의 값은 각 행에 있는 모든 수의 합 중 최솟값을 의미한다. 배열 A가 아래와 같은 경우 1행의 합은 6, 2행의 합은 4, 3행의 합은 15이다. 따라서, 배열 A의 값은 4이다.

1 2 3
2 1 1
4 5 6

배열은 회전 연산을 수행할 수 있다. 회전 연산은 세 정수 (r, c, s)로 이루어져 있고, 가장 왼쪽 윗 칸이 (r-s, c-s), 가장 오른쪽 아랫 칸이 (r+s, c+s)인 정사각형을 시계 방향으로 한 칸씩 돌린다는 의미이다. 배열의 칸 (r, c)는 r행 c열을 의미한다.

예를 들어, 배열 A의 크기가 6×6이고, 회전 연산이 (3, 4, 2)인 경우에는 아래 그림과 같이 회전하게 된다.

A[1][1]   A[1][2] → A[1][3] → A[1][4] → A[1][5] → A[1][6]
             ↑                                       ↓
A[2][1]   A[2][2]   A[2][3] → A[2][4] → A[2][5]   A[2][6]
             ↑         ↑                   ↓         ↓
A[3][1]   A[3][2]   A[3][3]   A[3][4]   A[3][5]   A[3][6]
             ↑         ↑                   ↓         ↓
A[4][1]   A[4][2]   A[4][3] ← A[4][4] ← A[4][5]   A[4][6]
             ↑                                       ↓
A[5][1]   A[5][2] ← A[5][3] ← A[5][4] ← A[5][5] ← A[5][6]

A[6][1]   A[6][2]   A[6][3]   A[6][4]   A[6][5]   A[6][6]

회전 연산이 두 개 이상이면, 연산을 수행한 순서에 따라 최종 배열이 다르다.

배열 A에 (3, 4, 2), (4, 2, 1) 순서로 연산을 수행하면 배열 A의 값은 12, (4, 2, 1), (3, 4, 2) 순서로 연산을 수행하면 15 이다.

배열 A와 사용 가능한 회전 연산이 주어졌을 때, 배열 A의 값의 최솟값을 구해보자. 회전 연산은 모두 한 번씩 사용해야 하며, 순서는 임의로 정해도 된다.

입력

첫째 줄에 배열 A의 크기 N, M, 회전 연산의 개수 K가 주어진다.

둘째 줄부터 N개의 줄에 배열 A에 들어있는 수 A[i][j]가 주어지고, 다음 K개의 줄에 회전 연산의 정보 r, c, s가 주어진다.

출력

배열 A의 값의 최솟값을 출력한다.

제한

  • 3 ≤ N, M ≤ 50
  • 1 ≤ K ≤ 6
  • 1 ≤ A[i][j] ≤ 100
  • 1 ≤ s
  • 1 ≤ r-s < r < r+s ≤ N
  • 1 ≤ c-s < c < c+s ≤ M

예제 입력 1

5 6 2
1 2 3 2 5 6
3 8 7 2 1 3
8 2 3 1 4 5
3 4 5 1 1 1
9 3 2 1 4 3
3 4 2
4 2 1

예제 출력 1

12

풀이

이 문제는 BruteForce 문제로 완전탐색 알고리즘을 사용해서 풀 수 있다.

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.IOException;
import java.util.ArrayList;

public class Main {
    static int N;
    static int M;
    static int K;
    static int[][] arr;
    static int[][] arr2;
    static Pair[] cal;
    static int min = Integer.MAX_VALUE;

    public static void main(String[] args) throws IOException{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] str = br.readLine().split(" ");
        N = Integer.parseInt(str[0]);
        M = Integer.parseInt(str[1]);
        K = Integer.parseInt(str[2]);
        arr = new int[N+1][M+1];
        arr2 = new int[N+1][M+1];
        cal = new Pair[K];

        for(int i=1; i<=N; i++) {
            String[] input = br.readLine().split(" ");
            for(int j=1; j<=M; j++) {
                arr[i][j] = Integer.parseInt(input[j-1]);
            }
        }

        for(int i=0; i<K; i++) {
            String[] input2 = br.readLine().split(" ");
            cal[i] = new Pair(Integer.parseInt(input2[0]), Integer.parseInt(input2[1]), Integer.parseInt(input2[2]));
        }

        ArrayList<Pair> list = new ArrayList<>();
        boolean[] visited = new boolean[K];
        select(list, visited);

        System.out.println(min);
    }

    static void select(ArrayList<Pair> list, boolean[] visited) {

        if(list.size()==K) {
            for(int i=1; i<=N; i++) {
                for(int j=1; j<=M; j++)
                    arr2[i][j] = arr[i][j];
            }

            for(int i=0; i<K; i++) {
                Pair p = list.get(i);
                rotate(p.r, p.c, p.s);
            }

            for(int i=1; i<=N; i++) {
                int sum = 0;
                for(int j=1; j<=M; j++) {
                    sum += arr2[i][j];
                }
                min = Math.min(min, sum);
            }
        }

        for(int i=0; i<K; i++) {
            if(!visited[i]) {
                visited[i] = true;
                list.add(cal[i]);
                select(list, visited);
                list.remove(list.size()-1);
                visited[i] = false;
            }
        }
    }

    static void rotate(int r, int c, int s) {
        int[][] temp = new int[N+1][M+1];
        int S = s;

        while(true) {
            if(S==0)
                break;

            for(int i=r-S; i<r+S; i++) {
                temp[i+1][c+S] = arr2[i][c+S];
            }

            for(int j=c+S; j>c-S; j--) {
                temp[r+S][j-1] = arr2[r+S][j];
            }

            for(int i=r+S; i>r-S; i--) {
                temp[i-1][c-S] = arr2[i][c-S];
            }

            for(int j=c-S; j<c+S; j++) {
                temp[r-S][j+1] = arr2[r-S][j];
            }
            S--;
        }

        for(int i=r-s; i<=r+s; i++) {
            for(int j=c-s; j<=c+s; j++) {
                if(i==r && j==c)
                    continue;
                arr2[i][j] = temp[i][j];
            }
        }
    }

    static class Pair {
        int r;
        int c;
        int s;

        public Pair(int r, int c, int s) {
            this.r = r;
            this.c = c;
            this.s = s;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글