[백준]#2166 다각형의 면적

SeungBird·2020년 8월 27일
0

⌨알고리즘(백준)

목록 보기
90/401

문제

2차원 평면상에 N(3 ≤ N ≤ 10,000)개의 점으로 이루어진 다각형이 있다. 이 다각형의 면적을 구하는 프로그램을 작성하시오.

입력

첫째 줄에 N이 주어진다. 다음 N개의 줄에는 다각형을 이루는 순서대로 N개의 점의 x, y좌표가 주어진다. 좌표값은 절댓값이 100,000을 넘지 않는 정수이다.

출력

첫째 줄에 면적을 출력한다. 면적을 출력할 때에는 소수점 아래 둘째 자리에서 반올림하여 첫째 자리까지 출력한다.

예제 입력 1

4
0 0
0 10
10 10
10 0

예제 출력 1

100.0

풀이

이 문제는 백터 외적을 통해 다각형의 넓이를 구하면 된다. CCW 알고리즘을 이용해서 풀면되는데 자료형에 신경을 써야한다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;

public class Main {
    static ArrayList<Pair> list = new ArrayList<>();

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int N = Integer.parseInt(br.readLine());

        for(int i=0; i<N; i++) {
            String[] input = br.readLine().split(" ");
            list.add(new Pair(Long.parseLong(input[0]), Long.parseLong(input[1])));
        }
        list.add(list.get(0));

        System.out.printf("%.1f", ccw());
    }

    static double ccw() {
        double a = 0;
        double b = 0;

        for(int i=0; i<list.size()-1; i++) {
            Pair X = list.get(i);
            Pair Y = list.get(i+1);

            a += X.x*Y.y;
            b += X.y*Y.x;
        }

       return Math.abs(a-b)/2;
    }

    static class Pair {
        long x;
        long y;

        public Pair(long x, long y) {
            this.x = x;
            this.y = y;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글