[백준]#2206 벽 부수고 이동하기

SeungBird·2020년 8월 27일
0

⌨알고리즘(백준)

목록 보기
72/401

문제

N×M의 행렬로 표현되는 맵이 있다. 맵에서 0은 이동할 수 있는 곳을 나타내고, 1은 이동할 수 없는 벽이 있는 곳을 나타낸다. 당신은 (1, 1)에서 (N, M)의 위치까지 이동하려 하는데, 이때 최단 경로로 이동하려 한다. 최단경로는 맵에서 가장 적은 개수의 칸을 지나는 경로를 말하는데, 이때 시작하는 칸과 끝나는 칸도 포함해서 센다.

만약에 이동하는 도중에 한 개의 벽을 부수고 이동하는 것이 좀 더 경로가 짧아진다면, 벽을 한 개 까지 부수고 이동하여도 된다.

맵이 주어졌을 때, 최단 경로를 구해 내는 프로그램을 작성하시오.

입력

첫째 줄에 N(1 ≤ N ≤ 1,000), M(1 ≤ M ≤ 1,000)이 주어진다. 다음 N개의 줄에 M개의 숫자로 맵이 주어진다. (1, 1)과 (N, M)은 항상 0이라고 가정하자.

출력

첫째 줄에 최단 거리를 출력한다. 불가능할 때는 -1을 출력한다.

예제 입력 1

6 4
0100
1110
1000
0000
0111
0000

예제 출력 1

15

예제 입력 2

4 4
0111
1111
1111
1110

예제 출력 2

-1

풀이

이 문제는 BFS 알고리즘을 이용해서 최단거리를 구하고 3차원 배열을 이용해서 벽을 부쉈을때와 안부쉈을 때를 기록한다.

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;

public class Main {
    static int[][] map;
    static int N;
    static int M;
    static int result = -1;
    static int[] dx = {-1, 1, 0, 0};
    static int[] dy = {0, 0, -1, 1};

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] str = br.readLine().split(" ");
        N = Integer.parseInt(str[0]);
        M = Integer.parseInt(str[1]);
        map = new int[N+1][M+1];

        for(int i=1; i<=N; i++) {
            String input = br.readLine();
            for(int j=1; j<=M; j++) {
                map[i][j] = input.charAt(j-1) - '0';
            }
        }
        BFS(1, 1);
        System.out.println(result);
    }


    public static void BFS(int x, int y) {
        Queue<Pair> queue = new LinkedList<>();
        boolean[][][] visited = new boolean[2][N+1][M+1];;
        visited[0][x][y]=true;
        queue.add(new Pair(x, y, 1,false));

        while(!queue.isEmpty()) {
            Pair p = queue.poll();

            if(p.x==N && p.y==M) {
                result = p.cnt;
                break;
            }

            for(int i=0; i<4; i++) {
                int X = p.x+dx[i];
                int Y = p.y+dy[i];
                int cnt = p.cnt+1;
                boolean isBreak = p.isBreak;

                if(X>=1 && Y>=1 && X<=N && Y<=M) {
                    if(isBreak) {
                        if (map[X][Y]==0 && !visited[1][X][Y]) {
                            visited[1][X][Y] = true;
                            queue.add(new Pair(X, Y, cnt, isBreak));
                        }
                    }

                    else {
                        if(!visited[0][X][Y]) {
                            if(map[X][Y]==1)
                                isBreak=true;
                            visited[0][X][Y] = true;
                            queue.add(new Pair(X, Y, cnt, isBreak));
                        }
                    }
                }
            }
        }
    }

    static class Pair {
        int x;
        int y;
        int cnt;
        boolean isBreak;

        public Pair(int x, int y, int cnt, boolean isBreak) {
            this.x=x;
            this.y=y;
            this.cnt=cnt;
            this.isBreak=isBreak;
        }
    }
}
profile
👶🏻Jr. Programmer

0개의 댓글