[BOJ] (10828) 스택 (Java)

zerokick·2023년 4월 22일
0

Coding Test

목록 보기
68/120
post-thumbnail

(10828) 스택 (Java)


시간 제한메모리 제한제출정답맞힌 사람정답 비율
0.5 초 (추가 시간 없음)256 MB208274736225369437.302%

문제

정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 다섯 가지이다.

push X: 정수 X를 스택에 넣는 연산이다.
pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
size: 스택에 들어있는 정수의 개수를 출력한다.
empty: 스택이 비어있으면 1, 아니면 0을 출력한다.
top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1

14
push 1
push 2
top
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
top

예제 출력 1

2
2
0
2
1
-1
0
1
-1
0
3

예제 입력 2

7
pop
top
push 123
top
pop
top
pop

예제 출력 2

-1
-1
123
123
-1
-1

출처

문제를 만든 사람: baekjoon
데이터를 추가한 사람: deunlee, djm03178

알고리즘 분류

자료 구조
스택

Solution

import java.io.*;
import java.util.List;
import java.util.ArrayList;
import java.util.StringTokenizer;

public class BOJ10828 <T> {
    public List<T> stack = new ArrayList<T>();
    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
        StringTokenizer st;

        int n = Integer.parseInt(br.readLine());

        BOJ10828<Integer> intClass = new BOJ10828<Integer>();

        for(int i = 0; i < n; i++) {
            st = new StringTokenizer(br.readLine());

            switch(st.nextToken()) {
                case "push" :
                    intClass.push(Integer.parseInt(st.nextToken()));
                    break;
                case "pop" :
                    bw.write(String.valueOf(intClass.pop()));
                    bw.newLine();
                    break;
                case "size" :
                    bw.write(String.valueOf(intClass.size()));
                    bw.newLine();
                    break;
                case "empty" :
                    bw.write(String.valueOf(intClass.empty()));
                    bw.newLine();
                    break;
                case "top" :
                    bw.write(String.valueOf(intClass.top()));
                    bw.newLine();
                    break;
            }
        }

        br.close();
        bw.flush();
        bw.close();

    }

    public void push(T x) {
        this.stack.add(x);
    }

    public int pop() {
        return this.stack.isEmpty() ? -1 : (int) this.stack.remove(this.stack.size()-1);
    }

    public int size() {
        return this.stack.size();
    }

    public int empty() {
        return this.stack.isEmpty() ? 1 : 0;
    }

    public int top() {
        return this.stack.isEmpty() ? -1 : (int) this.stack.get(this.stack.size()-1);
    }
}
profile
Opportunities are never lost. The other fellow takes those you miss.

0개의 댓글