포트를 연결해주기 위해 vSwitch를 생성한다.
pod - name - port number
연결할 포트를 네 개 생성해준다.
ex)
pod4-khy-win-1
pod4-khy-win-2
pod4-khy-1-3
pod4-khy-1-4
직렬 포트는 N9K를 PC(WIN10)와 직접적으로 연결(모니터)하기 위해 사용한다.
네트워크 어댑터를 통해 네트워크와 연결한다.
Win10를 Power ON하여 MTPutty 및 Putty를 다운받는다.
COM(N9K number) - Serial로 Session을 3개 설정한다.
Connection - Serial에서 Flow control을 None으로 변경한다.
사용했던 N9K를 재구성했기 때문에 setup으로 구성을 다시 해줬다.
사용하지 않는 포트가 구성에서 혼선을 주지 않기 위해 Disabled설정을 한다.
사용하지 않는 ethernet 3-64번까지 Port를 shutdown을 진행한다.
config)# int e1/3-64
config)# shutdown
config)# exit
config)# sh int status
사용하고자하는 포트를 No Swtichport로 변경한 뒤 IP를 추가한다.
config)# int e1/1-2
config)# no switchport
config)# int e1/1
config)# ip add 10.1.13.1/24
config)# no sh
config)# int e1/2
config)# ip add 10.1.14.1/24
config)# no sh
sh ip int brief
로 물리층, 데이터 링크층의 'up', 'down' 상태 및 IP 주소 정보 확인
config)# sh ip int brief
루프백을 설정하고 sh ip int bri로 상태를 확인한다.
config-if)# int loop0
config-if)# ip add 1.1.1.1/32
config-if)# sh ip int bri
no system default switchport?
nexus는 wr 저장 명령이 따로 없고 copy run start라는 명령어를 입력해야하기 때문에 cli alias name wr copy run start
명령어로 wr저장을 만들어준다.
사용하고자하는 포트를 No Swtichport로 변경한 뒤 IP를 추가한다.
config)# int e1/1
config)# no switchport
config)# int e1/1
config)# ip add 10.1.13.3/24
config)# no sh
물리층, 데이터 링크층의 'up', 'down' 상태 및 IP 주소 정보 확인
config)# sh int status
사용하지 않는 ethernet 1/2-4, 1/6-64번까지 Port를 shutdown을 진행한다.
vlan 110을 int e1/5로 switchport mode access하고, vlan을 확인한다.
config)# vlan 110
config)# int e1/5
config-if)# sw mode access
config-if)# sw access vlan 110
config-if)# exit
config)# show vlan
N9K는 vlan ip를 설정하기 전에 사용하고자하는 기능을 활성화 시킨다. feature (사용하고자하는 기능)
config)# feature interface-vlan
config)# int vlan 110
config)# ip add 200.1.110.1/24
config)# no sh
config)# exit
config)# sh ip int brief
N9K-4는 앞에서 설정한 것과 비슷하게 입력한다.
config)# sh ip int brie
N9K-1# ping 10.1.13.3
N9K-1# ping 10.1.14.4
#show cdp neighbors
feature ospf
!
int e1/1
no switchport
ip addr 10.1.13.1/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
!
int e1/2
no switchport
ip addr 10.1.14.1/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
!
int loopback 0
ip addr 1.1.1.1/32
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
!
router ospf 10
router-id 1.1.1.1
feature ospf
!
feature nv overlay
!
feature vn-segment-vlan-based
!
int e1/1
no switchport
ip addr 10.1.13.3/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
!
int e1/2
no switchport
ip addr 10.1.23.3/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
int loop0
ip addr 3.3.3.3/32
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
no shut
!
router ospf 10
router-id 3.3.3.3
!
int nve 1
source-interface loopback0
member vni 10110
ingress-replication protocol static
peer-ip 4.4.4.4
no shut
!
vlan 110
vn-segment 10110
!
int e1/5
switchport
switchport access vlan 110
feature ospf
!
feature nv overlay
!
feature vn-segment-vlan-based
!
int e1/1
no switchport
ip addr 10.1.24.4/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
!
int e1/2
no switchport
ip addr 10.1.14.4/24
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
mtu 9216
no shut
!
int loop0
ip addr 4.4.4.4/32
ip router ospf 10 area 0.0.0.0
ip ospf network point-to-point
no shut
!
router ospf 10
router-id 4.4.4.4
!
int nve 1
source-interface loopback0
member vni 10110
ingress-replication protocol static
peer-ip 3.3.3.3
no shut
!
vlan 120
vn-segment 10110
!
int e1/5
switchport
switchport access vlan 120
feature ospf
feature bgp
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay
nv overlay evpn
feature ospf
feature bgp
feature interface-vlan
nv overlay evpn
N9K-3, N9K-4는 BGP Neighbor를 설정합니다.
N9K-1는 Route Reflector로 설정합니다.
feature bgp
nv overlay evpn
router bgp 65000
router-id 3.3.3.3
neighbor 1.1.1.1
remote-as 65000
update-source lo 0
address-family l2vpn evpn
send-community extended
feature bgp
nv overlay evpn
router bgp 65000
router-id 4.4.4.4
neighbor 1.1.1.1
remote-as 65000
update-source lo 0
address-family l2vpn evpn
send-community extended
N9K-3, N9K-4는 BGP Neighbor를 설정합니다.
N9K-1는 Route Reflector로 설정합니다.
feature bgp
nv overlay evpn
router bgp 65000
router-id 1.1.1.1
neighbor 3.3.3.3
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community extended
route-reflector-client
neighbor 4.4.4.4
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community extended
route-reflector-client
#show bgp l2vpn evpn summary
->BGP 라우터에서 L2vpn에 대한 neighbor 관계 확인
#show bgp all summary
->BGP 라우터에서 모든 neghbor 관계 확인
VRF Name은 VRF01로 설정
VLAN 100과 VxLAN 10100과 연동
SVI 100 생성후, VRF 지정
VRF01에 VNI 10100 연동
vrf context VRF01
vlan 100
vn-segment 10100
interface vlan 100
no shutdown
vrf member VRF01
ip forward
vrf context VRF01
vni 10100
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
VTEP의 Source는 Loopback 0를 사용합니다.
VTEP Peer IP는 BGP를 통해 확인되도록 설정합니다.
interface nve 1
no shutdown
source-interface loopback 0
host-reachability protocol bgp
member vni 10100 associate-vrf
VLAN 110은 VxLAN 10110과 연동합니다.
VNE 1에 VxLAN 10110을 적용합니다.
Replication protocol은 BGP로 설정합니다.
vlan 110
vn-segment 10110
interface vlan 110
no shutdown
vrf member VRF01
ip add 200.1.110.254/24
fabric forwarding mode anycast-gateway
fabric forwarding anycast-gateway-mac 0000.1111.2222
interface nve 1
member vni 10110
ingress-replication protocol bgp
RD, RT는 Auto로 지정합니다.
evpn
vni 10110 l2
rd auto
route-target import auto
route-target export auto
VLAN 120은 VxLAN 10120과 연동합니다.
VNE 1에 VxLAN 10120을 적용합니다.
Replication protocol은 BGP로 설정합니다.
vlan 120
vn-segment 10120
interface vlan 120
no shutdown
vrf member VRF01
ip add 200.1.120.254/24
fabric forwarding mode anycast-gateway
fabric forwarding anycast-gateway-mac 0000.1111.2222
interface nve 1
member vni 10120
ingress-replication protocol bgp
RD, RT는 Auto로 지정합니다.
N9K-4
evpn
vni 10120 l2
rd auto
route-target import auto
route-target export auto
interface e1/5
switchport mode access
switchport access vlan 110
no shutdown
interface e1/5
switchport mode access
switchport access vlan 120
no shutdown